CVE-2025-62372 vLLM vulnerable to DoS with incorrect shape of multimodal embedding inputs

High 8.3 Published Updated

Attackers can crash the vLLM engine by sending multimodal embedding inputs with incorrect shapes, causing a denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-62372?

CVE-2025-62372 is a high-severity denial of service vulnerability in Vllm Vllm, published on 21 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.

Weakness: CWE-129

Which versions are affected by CVE-2025-62372?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.5.50.11.1
vllm PyPIFrom 0.5.50.11.1
vllm PyPIFrom 0.5.50.11.1

Products include Vllm Vllm.

How do I fix CVE-2025-62372?

Upgrade vllm to 0.11.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-62372 being exploited?

There is no known exploitation of CVE-2025-62372 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-pmqf-x6x8-p7qw, PYSEC-2026-2019.

Is CVE-2025-62372 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free