# CVE-2025-62372: vLLM vulnerable to DoS with incorrect shape of multimodal embedding inputs

> Attackers can crash the vLLM engine by sending multimodal embedding inputs with incorrect shapes, causing a denial of service.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2025
- **Updated:** 24 Nov 2025
- **Also known as:** GHSA-pmqf-x6x8-p7qw, PYSEC-2026-2019

## What is CVE-2025-62372?

CVE-2025-62372 is a high-severity denial of service vulnerability in Vllm Vllm, published on 21 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.

Weakness: CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2025-62372?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.5.5 | 0.11.1 |
| `vllm` | PyPI | From 0.5.5 | 0.11.1 |
| `vllm` | PyPI | From 0.5.5 | 0.11.1 |

Products: Vllm Vllm.

## How do I fix CVE-2025-62372?

Upgrade vllm to 0.11.1 or later.

## Is CVE-2025-62372 being exploited?

There is no known exploitation of CVE-2025-62372 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62372 and fix it if it is affected.

What it is: CVE-2025-62372 is a high-severity denial of service vulnerability in Vllm Vllm, published on 21 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62372 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.5.5; fixed in 0.11.1
- vllm (PyPI): affected from 0.5.5; fixed in 0.11.1
- vllm (PyPI): affected from 0.5.5; fixed in 0.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62372/ (Markdown: https://insights.sbomify.com/CVE-2025-62372/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62372
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62372
- OSV: https://osv.dev/vulnerability/CVE-2025-62372

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62372/
Summaries are generated and may contain mistakes; the official description above is the record.
