{"answers":{"affected":"3 open source packages ship an affected version, including pipecat-ai. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62373 exists.","fix":"Upgrade pipecat-ai to 0.0.94 or later.","what":"CVE-2025-62373 is a critical unsafe deserialization vulnerability in pipecat-ai pipecat, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62373 and fix it if it is affected.\n\nWhat it is: CVE-2025-62373 is a critical unsafe deserialization vulnerability in pipecat-ai pipecat, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62373 exists.\n\nAffected packages and fixed versions:\n- pipecat-ai (PyPI): affected from 0.0.41; fixed in 0.0.94\n- pipecat-ai (PyPI): affected from 0.0.41; fixed in 0.0.94\n- pipecat-ai (PyPI): affected from 0.0.41; fixed in 0.0.94\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62373/ (Markdown: https://insights.sbomify.com/CVE-2025-62373/index.md)","id":"CVE-2025-62373","markdown":"https://insights.sbomify.com/CVE-2025-62373/index.md","name":"CVE-2025-62373","record":{"aliases":["GHSA-c2jg-5cp7-6wc7","PYSEC-2026-458"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Python voice agent framework","requires_auth":"none","summary":"Remote attackers can execute arbitrary code on Pipecat servers using unsafe pickle deserialization in the optional LivekitFrameSerializer.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pipecat","vendor":"pipecat"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Pipecat is an open-source Python framework for building real-time voice and multimodal conversational agents. Versions 0.0.41 through 0.0.93 have a vulnerability in `LivekitFrameSerializer` – an optional, non-default, undocumented frame serializer class (now deprecated) intended for LiveKit integration. The class's `deserialize()` method uses Python's `pickle.loads()` on data received from WebSocket clients without any validation or sanitization. This means that a malicious WebSocket client can send a crafted pickle payload to execute arbitrary code on the Pipecat server. The vulnerable code resides in `src/pipecat/serializers/livekit.py` (around line 73), where untrusted WebSocket message data is passed directly into `pickle.loads()` for deserialization. If a Pipecat server is configured to use LivekitFrameSerializer and is listening on an external interface (e.g. 0.0.0.0), an attacker on the network (or the internet, if the service is exposed) could achieve remote code execution (RCE) on the server by sending a malicious pickle payload. Version 0.0.94 contains a fix. Users of Pipecat should avoid or replace unsafe deserialization and improve network security configuration. The best mitigation is to stop using the vulnerable LivekitFrameSerializer altogether. Those who require LiveKit functionality should upgrade to the latest Pipecat version and switch to the recommended `LiveKitTransport` or another secure method provided by the framework. Additionally, always follow secure coding practices: never trust client-supplied data, and avoid Python pickle (or similar unsafe deserialization) in network-facing components.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Pipecat vulnerable to Remote Code Execution by Pickle Deserialization via LivekitFrameSerializer","id":"CVE-2025-62373","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Parse Javascript SDK vulnerable to prototype pollution in `Parse.Object` and internal APIs","id":"CVE-2025-62374"},"packages":[{"ecosystem":"PyPI","fixed":["0.0.94"],"introduced":["0.0.41"],"last_affected":[],"package":"pipecat-ai","purl":null,"source":"GHSA-c2jg-5cp7-6wc7"},{"ecosystem":"PyPI","fixed":["0.0.94"],"introduced":["0.0.41"],"last_affected":[],"package":"pipecat-ai","purl":"pkg:pypi/pipecat-ai","source":"GHSA-c2jg-5cp7-6wc7"},{"ecosystem":"PyPI","fixed":["0.0.94"],"introduced":["0.0.41"],"last_affected":[],"package":"pipecat-ai","purl":"pkg:pypi/pipecat-ai","source":"PYSEC-2026-458"}],"prev":{"headline":"vLLM vulnerable to DoS with incorrect shape of multimodal embedding inputs","id":"CVE-2025-62372"},"products":["pipecat"],"published":"2026-04-23","related":[{"cvss_score":7.5,"headline":"Pipecat: Telephony WebSocket `/ws` Unauthenticated Call-Control Abuse via Attacker-Supplied Call SID","id":"CVE-2026-54695","kev_date_added":null,"published":"2026-07-09"},{"cvss_score":7.5,"headline":"Pipecat: Path Traversal in Pipecat Runner `/files` Endpoint — Arbitrary File Read via `%2F`-Encoded Separator","id":"CVE-2026-44716","kev_date_added":null,"published":"2026-06-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-23","vendors":["pipecat-ai"]},"summary":"Remote attackers can execute arbitrary code on Pipecat servers using unsafe pickle deserialization in the optional LivekitFrameSerializer.","url":"https://insights.sbomify.com/CVE-2025-62373/"}