# CVE-2025-62373: Pipecat vulnerable to Remote Code Execution by Pickle Deserialization via LivekitFrameSerializer

> Remote attackers can execute arbitrary code on Pipecat servers using unsafe pickle deserialization in the optional LivekitFrameSerializer.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-c2jg-5cp7-6wc7, PYSEC-2026-458

## What is CVE-2025-62373?

CVE-2025-62373 is a critical unsafe deserialization vulnerability in pipecat-ai pipecat, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pipecat is an open-source Python framework for building real-time voice and multimodal conversational agents. Versions 0.0.41 through 0.0.93 have a vulnerability in `LivekitFrameSerializer` – an optional, non-default, undocumented frame serializer class (now deprecated) intended for LiveKit integration. The class's `deserialize()` method uses Python's `pickle.loads()` on data received from WebSocket clients without any validation or sanitization. This means that a malicious WebSocket client can send a crafted pickle payload to execute arbitrary code on the Pipecat server. The vulnerable code resides in `src/pipecat/serializers/livekit.py` (around line 73), where untrusted WebSocket message data is passed directly into `pickle.loads()` for deserialization. If a Pipecat server is configured to use LivekitFrameSerializer and is listening on an external interface (e.g. 0.0.0.0), an attacker on the network (or the internet, if the service is exposed) could achieve remote code execution (RCE) on the server by sending a malicious pickle payload. Version 0.0.94 contains a fix. Users of Pipecat should avoid or replace unsafe deserialization and improve network security configuration. The best mitigation is to stop using the vulnerable LivekitFrameSerializer altogether. Those who require LiveKit functionality should upgrade to the latest Pipecat version and switch to the recommended `LiveKitTransport` or another secure method provided by the framework. Additionally, always follow secure coding practices: never trust client-supplied data, and avoid Python pickle (or similar unsafe deserialization) in network-facing components.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-62373?

3 open source packages ship an affected version, including pipecat-ai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pipecat-ai` | PyPI | From 0.0.41 | 0.0.94 |
| `pipecat-ai` | PyPI | From 0.0.41 | 0.0.94 |
| `pipecat-ai` | PyPI | From 0.0.41 | 0.0.94 |

Products: Pipecat Pipecat.

## How do I fix CVE-2025-62373?

Upgrade pipecat-ai to 0.0.94 or later.

## Is CVE-2025-62373 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62373 exists.

## Other vulnerabilities in pipecat-ai pipecat

- [CVE-2026-54695](https://insights.sbomify.com/CVE-2026-54695/): Pipecat: Telephony WebSocket `/ws` Unauthenticated Call-Control Abuse via Attacker-Supplied Call SID (high 7.5)
- [CVE-2026-44716](https://insights.sbomify.com/CVE-2026-44716/): Pipecat: Path Traversal in Pipecat Runner `/files` Endpoint — Arbitrary File Read via `%2F`-Encoded Separator (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62373 and fix it if it is affected.

What it is: CVE-2025-62373 is a critical unsafe deserialization vulnerability in pipecat-ai pipecat, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62373 exists.

Affected packages and fixed versions:
- pipecat-ai (PyPI): affected from 0.0.41; fixed in 0.0.94
- pipecat-ai (PyPI): affected from 0.0.41; fixed in 0.0.94
- pipecat-ai (PyPI): affected from 0.0.41; fixed in 0.0.94

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62373/ (Markdown: https://insights.sbomify.com/CVE-2025-62373/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62373
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62373
- OSV: https://osv.dev/vulnerability/CVE-2025-62373

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62373/
Summaries are generated and may contain mistakes; the official description above is the record.
