# CVE-2025-62374: Parse Javascript SDK vulnerable to prototype pollution in `Parse.Object` and internal APIs


- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 14 Oct 2025
- **Updated:** 14 Oct 2025
- **Also known as:** GHSA-9f2h-7v79-mxw3

## What is CVE-2025-62374?

CVE-2025-62374 is a medium-severity vulnerability in parse-community Parse-SDK-JS, published on 14 Oct 2025. 

### Official description

Parse Javascript SDK provides access to the powerful Parse Server backend from your JavaScript app. Prior to 7.0.0, injection of malicious payload allows attacker to remotely execute arbitrary code.  ParseObject.fromJSON, ParseObject.pin, ParseObject.registerSubclass, ObjectStateMutations (internal), and encode/decode (internal) are affected. This vulnerability is fixed in 7.0.0.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2025-62374?

2 open source packages ship an affected version, including parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse` | npm | All versions | 7.0.0 |
| `parse` | npm | All versions | 7.0.0 |

## How do I fix CVE-2025-62374?

Upgrade parse to 7.0.0 or later.

## Is CVE-2025-62374 being exploited?

There is no known exploitation of CVE-2025-62374 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62374 and fix it if it is affected.

What it is: CVE-2025-62374 is a medium-severity vulnerability in parse-community Parse-SDK-JS, published on 14 Oct 2025. 
Exploitation: There is no known exploitation of CVE-2025-62374 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse (npm): affected all versions; fixed in 7.0.0
- parse (npm): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62374/ (Markdown: https://insights.sbomify.com/CVE-2025-62374/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62374
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62374
- OSV: https://osv.dev/vulnerability/CVE-2025-62374

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62374/
Summaries are generated and may contain mistakes; the official description above is the record.
