CVE-2025-62378 CommandKit exposes incorrect command name in context object for message command aliases

Medium 6.1 Published Updated

Developers relying on canonical command names for access control may bypass restrictions when aliases are used, potentially allowing unauthorized command execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-62378?

CVE-2025-62378 is a medium-severity vulnerability in underctrl-io commandkit, published on 15 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

CommandKit is the discord.js meta-framework for building Discord bots. In versions 1.2.0-rc.1 through 1.2.0-rc.11, a logic flaw exists in the message command handler that affects how the commandName property is exposed to both middleware functions and command execution contexts when handling command aliases. When a message command is invoked using an alias, the ctx.commandName value reflects the alias rather than the canonical command name. This occurs in both middleware functions and within the command's own run function. Although not explicitly documented, CommandKit's examples and guidance around middleware usage implicitly convey that ctx.commandName represents the canonical command identifier. Middleware examples in the documentation consistently use ctx.commandName to reference the command being executed. Developers who assume ctx.commandName is canonical may introduce unintended behavior when relying on it for logic such as permission checks, rate limiting, or audit logging. This could allow unauthorized command execution or inaccurate access control decisions. Slash commands and context menu commands are not affected. This issue has been patched in version 1.2.0-rc.12, where ctx.commandName now consistently returns the actual canonical command name regardless of the alias used to invoke it.

Weakness: CWE-706

Which versions are affected by CVE-2025-62378?

2 open source packages ship an affected version, including commandkit.

PackageAffectedFixed in
commandkit npmFrom 1.2.0-rc.11.2.0-rc.12
commandkit npmFrom 1.2.0-rc.11.2.0-rc.12

How do I fix CVE-2025-62378?

Upgrade commandkit to 1.2.0-rc.12 or later.

Is CVE-2025-62378 being exploited?

There is no known exploitation of CVE-2025-62378 in the wild and no public exploit code.

Sources

Also known as GHSA-fhwm-pc6r-4h2f.

Is CVE-2025-62378 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free