# CVE-2025-6238: AI Engine 2.8.4 - Insecure OAuth Implementation

> Unauthenticated attackers can intercept authorization codes and obtain access tokens via an open redirect in the AI Engine WordPress plugin's OAuth flow.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 4 Jul 2025
- **Updated:** 8 Jul 2025
- **Also known as:** GHSA-6wxr-g84w-3h8x

## What is CVE-2025-6238?

CVE-2025-6238 is a high-severity vulnerability in tigroumeow AI Engine, published on 4 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The AI Engine plugin for WordPress is vulnerable to open redirect in version 2.8.4. This is due to an insecure OAuth implementation, as the 'redirect_uri' parameter is missing validation during the authorization flow. This makes it possible for unauthenticated attackers to intercept the authorization code and obtain an access token by redirecting the user to an attacker-controlled URI. Note: OAuth is disabled, the 'Meow_MWAI_Labs_OAuth' class is not loaded in the plugin in the patched version 2.8.5.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-6238?

It affects 1 product.


Products: Meowapps Ai Engine.

## How do I fix CVE-2025-6238?

No fix has been published for CVE-2025-6238 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-6238 being exploited?

There is no known exploitation of CVE-2025-6238 in the wild and no public exploit code.

## Other vulnerabilities in tigroumeow AI Engine

- [CVE-2023-51409](https://insights.sbomify.com/CVE-2023-51409/): WordPress AI Engine plugin <= 1.9.98 - Unauthenticated Arbitrary File Upload vulnerability (critical 10.0)
- [CVE-2024-34440](https://insights.sbomify.com/CVE-2024-34440/): WordPress AI Engine plugin <= 2.2.63 - Auth. Arbitrary File Upload vulnerability (critical 9.1)
- [CVE-2024-29100](https://insights.sbomify.com/CVE-2024-29100/): WordPress AI Engine plugin <= 2.1.4 - Arbitrary File Upload vulnerability (critical 9.1)
- [CVE-2025-5071](https://insights.sbomify.com/CVE-2025-5071/): AI Engine 2.8.0 - 2.8.3 - Authenticated (Subscriber+) Insufficient Authorization to Privilege Escalation via MCP (high 8.8)
- [CVE-2024-10499](https://insights.sbomify.com/CVE-2024-10499/): AI-Engine < 2.6.5 - Admin+ SQLi (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6238 and fix it if it is affected.

What it is: CVE-2025-6238 is a high-severity vulnerability in tigroumeow AI Engine, published on 4 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-6238 in the wild and no public exploit code.

Affected product: tigroumeow AI Engine. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6238/ (Markdown: https://insights.sbomify.com/CVE-2025-6238/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6238
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6238
- OSV: https://osv.dev/vulnerability/CVE-2025-6238

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6238/
Summaries are generated and may contain mistakes; the official description above is the record.
