# CVE-2025-62381: sveltekit-superforms Prototype Pollution in `parseFormData` function of `formData.js`

> Prototype pollution in sveltekit-superforms allows attackers to inject properties into Object.prototype, causing denial of service or potential remote code execution.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:H/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2025
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-hwmc-4c8j-xxj7

## What is CVE-2025-62381?

CVE-2025-62381 is a high-severity vulnerability in ciscoheat sveltekit-superforms, published on 15 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

sveltekit-superforms makes SvelteKit forms a pleasure to use. sveltekit-superforms v2.27.3 and prior are susceptible to a prototype pollution vulnerability within the parseFormData function of formData.js. An attacker can inject string and array properties into Object.prototype, leading to denial of service, type confusion, and potential remote code execution in downstream applications that rely on polluted objects. This vulnerability is fixed in 2.27.4.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2025-62381?

2 open source packages ship an affected version, including sveltekit-superforms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sveltekit-superforms` | npm | All versions | 2.27.4 |
| `sveltekit-superforms` | npm | All versions | 2.27.4 |

## How do I fix CVE-2025-62381?

Upgrade sveltekit-superforms to 2.27.4 or later.

## Is CVE-2025-62381 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62381 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62381 and fix it if it is affected.

What it is: CVE-2025-62381 is a high-severity vulnerability in ciscoheat sveltekit-superforms, published on 15 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62381 exists.

Affected packages and fixed versions:
- sveltekit-superforms (npm): affected all versions; fixed in 2.27.4
- sveltekit-superforms (npm): affected all versions; fixed in 2.27.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62381/ (Markdown: https://insights.sbomify.com/CVE-2025-62381/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62381
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62381
- OSV: https://osv.dev/vulnerability/CVE-2025-62381

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62381/
Summaries are generated and may contain mistakes; the official description above is the record.
