CVE-2025-62394 Moodle: quiz notifications sent to suspended participants
Moodle sends quiz notifications to suspended users, leaking limited course information to unauthorized participants.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-62394?
CVE-2025-62394 is a medium-severity vulnerability in Moodle Moodle, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Moodle failed to verify enrolment status correctly when sending quiz notifications. As a result, suspended or inactive users might receive quiz-related messages, leaking limited course information.
Weakness: CWE-863
Which versions are affected by CVE-2025-62394?
5 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 4.5.0-beta | 4.5.7 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.7 |
moodle/moodle Packagist | From 5.0.0-beta | 5.0.3 |
moodle/moodle Packagist | From 5.0.0-beta | 5.0.3 |
moodle Bitnami | From 4.5.0 | 4.5.7, 5.0.3 |
Products include Moodle Moodle.
How do I fix CVE-2025-62394?
Upgrade moodle/moodle to a fixed version for your release line: 4.5.7 or 5.0.3.
Is CVE-2025-62394 being exploited?
There is no known exploitation of CVE-2025-62394 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-62394, GHSA-8fcv-4qp9-pg32, UBUNTU-CVE-2025-62394.