CVE-2025-62395 Moodle: external cohort search service leaks system cohort data
Attackers with lower-context permissions can access restricted system cohort data via the external search service, exposing administrative information.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-62395?
CVE-2025-62395 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw in the cohort search web service allowed users with permissions in lower contexts to access cohort information from the system context, revealing restricted administrative data.
Weakness: CWE-284
Which versions are affected by CVE-2025-62395?
1 open source package ship an affected version, including moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle Bitnami | From 4.1.0 | 4.1.21, 4.4.11, 4.5.7, 5.0.3 |
Products include Moodle Moodle.
How do I fix CVE-2025-62395?
Upgrade moodle to a fixed version for your release line: 4.1.21, 4.4.11, 4.5.7 or 5.0.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-62395 being exploited?
There is no known exploitation of CVE-2025-62395 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-62395, GHSA-7f5w-xxw9-mqgp, UBUNTU-CVE-2025-62395.