{"answers":{"affected":"1 open source package ship an affected version, including moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-62395 in the wild and no public exploit code.","fix":"Upgrade moodle to a fixed version for your release line: 4.1.21, 4.4.11, 4.5.7 or 5.0.3.","what":"CVE-2025-62395 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62395 and fix it if it is affected.\n\nWhat it is: CVE-2025-62395 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-62395 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle (Bitnami): affected from 4.1.0; fixed in 4.1.21, 4.4.11, 4.5.7, 5.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62395/ (Markdown: https://insights.sbomify.com/CVE-2025-62395/index.md)","id":"CVE-2025-62395","markdown":"https://insights.sbomify.com/CVE-2025-62395/index.md","name":"CVE-2025-62395","record":{"aliases":["BIT-moodle-2025-62395","GHSA-7f5w-xxw9-mqgp","UBUNTU-CVE-2025-62395"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Attackers with lower-context permissions can access restricted system cohort data via the external search service, exposing administrative information.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"A flaw in the cohort search web service allowed users with permissions in lower contexts to access cohort information from the system context, revealing restricted administrative data.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle: external cohort search service leaks system cohort data","id":"CVE-2025-62395","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"missing_authorization","year":"2025"},"n_packages":1,"n_references":2,"next":{"headline":"Moodle: router (r.php) could expose application directories","id":"CVE-2025-62396"},"packages":[{"ecosystem":"Bitnami","fixed":["4.1.21","4.4.11","4.5.7","5.0.3"],"introduced":["4.1.0","4.4.0","4.5.0","5.0.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2025-62395"}],"prev":{"headline":"Moodle: quiz notifications sent to suspended participants","id":"CVE-2025-62394"},"products":["moodle:moodle"],"published":"2025-10-23","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-23","vendors":["moodle"]},"summary":"Attackers with lower-context permissions can access restricted system cohort data via the external search service, exposing administrative information.","url":"https://insights.sbomify.com/CVE-2025-62395/"}