CVE-2025-62396 Moodle: router (r.php) could expose application directories
Improper error handling in Moodle's router may expose internal directory listings when specific HTTP headers are misconfigured.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-62396?
CVE-2025-62396 is a medium-severity vulnerability in Moodle Moodle, published on 23 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An error-handling issue in the Moodle router (r.php) could cause the application to display internal directory listings when specific HTTP headers were not properly configured.
Weakness: CWE-548
Which versions are affected by CVE-2025-62396?
5 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 4.5.0-beta | 4.5.7 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.7 |
moodle/moodle Packagist | From 5.0.0-beta | 5.0.3 |
moodle/moodle Packagist | From 5.0.0-beta | 5.0.3 |
moodle Bitnami | From 4.5.0 | 4.5.7, 5.0.3 |
Products include Moodle Moodle.
How do I fix CVE-2025-62396?
Upgrade moodle/moodle to a fixed version for your release line: 4.5.7 or 5.0.3.
Is CVE-2025-62396 being exploited?
There is no known exploitation of CVE-2025-62396 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-62396, GHSA-c5cj-xp43-qcc3, UBUNTU-CVE-2025-62396.