{"answers":{"affected":"1 open source package ship an affected version, including moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-62397 in the wild and no public exploit code.","fix":"Upgrade moodle to 5.0.3 or later.","what":"CVE-2025-62397 is a medium-severity vulnerability in Moodle Moodle, published on 23 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62397 and fix it if it is affected.\n\nWhat it is: CVE-2025-62397 is a medium-severity vulnerability in Moodle Moodle, published on 23 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-62397 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle (Bitnami): affected from 5.0.0; fixed in 5.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62397/ (Markdown: https://insights.sbomify.com/CVE-2025-62397/index.md)","id":"CVE-2025-62397","markdown":"https://insights.sbomify.com/CVE-2025-62397/index.md","name":"CVE-2025-62397","record":{"aliases":["BIT-moodle-2025-62397","GHSA-rc65-mhj4-hp4r","UBUNTU-CVE-2025-62397"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"Attackers can enumerate valid course IDs by observing JSON responses instead of 404 errors, facilitating reconnaissance against Moodle installations.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"The router’s inconsistent response to invalid course IDs allowed attackers to infer which course IDs exist, potentially aiding reconnaissance.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle: router produces json instead of 404 error for invalid course id","id":"CVE-2025-62397","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"information_disclosure","year":"2025"},"n_packages":1,"n_references":2,"next":{"headline":"Moodle: possible to bypass mfa","id":"CVE-2025-62398"},"packages":[{"ecosystem":"Bitnami","fixed":["5.0.3"],"introduced":["5.0.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2025-62397"}],"prev":{"headline":"Moodle: router (r.php) could expose application directories","id":"CVE-2025-62396"},"products":["moodle:moodle"],"published":"2025-10-23","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-23","vendors":["moodle"]},"summary":"Attackers can enumerate valid course IDs by observing JSON responses instead of 404 errors, facilitating reconnaissance against Moodle installations.","url":"https://insights.sbomify.com/CVE-2025-62397/"}