CVE-2025-62399 Moodle: password brute force risk when mobile/web services enabled
Attackers can bypass rate limiting on Moodle mobile and web service endpoints to perform brute-force attacks and take over user accounts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-62399?
CVE-2025-62399 is a high-severity vulnerability in Moodle Moodle, published on 23 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Moodle’s mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.
Weakness: CWE-307
Which versions are affected by CVE-2025-62399?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.21 |
moodle/moodle Packagist | All versions | 4.1.21 |
moodle/moodle Packagist | From 4.2.0-beta | 4.4.11 |
moodle/moodle Packagist | From 4.2.0-beta | 4.4.11 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.7 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.7 |
3 more packages
moodle/moodle Packagist | From 5.0.0-beta | 5.0.3 |
moodle/moodle Packagist | From 5.0.0-beta | 5.0.3 |
moodle Bitnami | From 4.1.0 | 4.1.21, 4.4.11, 4.5.7, 5.0.3 |
Products include Moodle Moodle.
How do I fix CVE-2025-62399?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.21, 4.4.11, 4.5.7 or 5.0.3.
Is CVE-2025-62399 being exploited?
There is no known exploitation of CVE-2025-62399 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-62399, GHSA-m58f-9pvv-8mp2, UBUNTU-CVE-2025-62399.