CVE-2025-62400 Moodle: hidden group names visible to event creators
Attackers with calendar event creation permissions can view names of hidden groups, exposing private restricted group information.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-62400?
CVE-2025-62400 is a medium-severity vulnerability in Moodle Moodle, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Moodle exposed the names of hidden groups to users who had permission to create calendar events but not to view hidden groups. This could reveal private or restricted group information.
Weakness: CWE-200
Which versions are affected by CVE-2025-62400?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.21 |
moodle/moodle Packagist | All versions | 4.1.21 |
moodle/moodle Packagist | From 4.2.0-beta | 4.4.11 |
moodle/moodle Packagist | From 4.2.0-beta | 4.4.11 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.7 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.7 |
3 more packages
moodle/moodle Packagist | From 5.0.0-beta | 5.0.3 |
moodle/moodle Packagist | From 5.0.0-beta | 5.0.3 |
moodle Bitnami | From 4.1.0 | 4.1.21, 4.4.11, 4.5.7, 5.0.3 |
Products include Moodle Moodle.
How do I fix CVE-2025-62400?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.21, 4.4.11, 4.5.7 or 5.0.3.
Is CVE-2025-62400 being exploited?
There is no known exploitation of CVE-2025-62400 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-62400, GHSA-422v-w6c5-vq42, UBUNTU-CVE-2025-62400.