# CVE-2025-62401: Moodle: possible to bypass timer in timed assignments

> Students can bypass time restrictions in Moodle timed assignments, gaining unauthorized extra time to complete assessments.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Oct 2025
- **Updated:** 23 Oct 2025
- **Also known as:** BIT-moodle-2025-62401, GHSA-w29j-8phw-ffjf, UBUNTU-CVE-2025-62401

## What is CVE-2025-62401?

CVE-2025-62401 is a medium-severity vulnerability in Moodle Moodle, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue in Moodle’s timed assignment feature allowed students to bypass the time restriction, potentially giving them more time than allowed to complete an assessment.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-62401?

9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 4.1.21 |
| `moodle/moodle` | Packagist | All versions | 4.1.21 |
| `moodle/moodle` | Packagist | From 4.2.0-beta | 4.4.11 |
| `moodle/moodle` | Packagist | From 4.2.0-beta | 4.4.11 |
| `moodle/moodle` | Packagist | From 4.5.0-beta | 4.5.7 |
| `moodle/moodle` | Packagist | From 4.5.0-beta | 4.5.7 |
| `moodle/moodle` | Packagist | From 5.0.0-beta | 5.0.3 |
| `moodle/moodle` | Packagist | From 5.0.0-beta | 5.0.3 |
| `moodle` | Bitnami | From 4.1.0 | 4.1.21, 4.4.11, 4.5.7, 5.0.3 |

Products: Moodle Moodle.

## How do I fix CVE-2025-62401?

Upgrade moodle/moodle to a fixed version for your release line: 4.1.21, 4.4.11, 4.5.7 or 5.0.3.

## Is CVE-2025-62401 being exploited?

There is no known exploitation of CVE-2025-62401 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62401 and fix it if it is affected.

What it is: CVE-2025-62401 is a medium-severity vulnerability in Moodle Moodle, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62401 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.21
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.21
- moodle/moodle (Packagist): affected from 4.2.0-beta; fixed in 4.4.11
- moodle/moodle (Packagist): affected from 4.2.0-beta; fixed in 4.4.11
- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.7
- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.7
- moodle/moodle (Packagist): affected from 5.0.0-beta; fixed in 5.0.3
- moodle/moodle (Packagist): affected from 5.0.0-beta; fixed in 5.0.3
- moodle (Bitnami): affected from 4.1.0; fixed in 4.1.21, 4.4.11, 4.5.7, 5.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62401/ (Markdown: https://insights.sbomify.com/CVE-2025-62401/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62401
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62401
- OSV: https://osv.dev/vulnerability/CVE-2025-62401

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62401/
Summaries are generated and may contain mistakes; the official description above is the record.
