# CVE-2025-62409: Envoy allows large requests and responses to cause TCP connection pool crash

> Attackers can cause TCP connection pool crashes in Envoy proxy by sending large requests or responses during connection closure, leading to denial of service.

- **Severity:** Medium 6.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2025
- **Updated:** 16 Oct 2025
- **Also known as:** BIT-envoy-2025-62409, GHSA-pq33-4jxh-hgm3

## What is CVE-2025-62409?

CVE-2025-62409 is a medium-severity vulnerability in Envoyproxy Envoy, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is a cloud-native, open source edge and service proxy. Prior to 1.36.1, 1.35.5, 1.34.9, and 1.33.10, large requests and responses can potentially trigger TCP connection pool crashes due to flow control management in Envoy. It will happen when the connection is closing but upstream data is still coming, resulting in a buffer watermark callback nullptr reference. The vulnerability impacts TCP proxy and HTTP 1 & 2 mixed use cases based on ALPN. This vulnerability is fixed in 1.36.1, 1.35.5, 1.34.9, and 1.33.10.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2025-62409?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | All versions | 1.33.10, 1.34.9, 1.35.5, 1.36.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2025-62409?

Upgrade envoy to a fixed version for your release line: 1.33.10, 1.34.9, 1.35.5 or 1.36.1.

## Is CVE-2025-62409 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62409 exists.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62409 and fix it if it is affected.

What it is: CVE-2025-62409 is a medium-severity vulnerability in Envoyproxy Envoy, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62409 exists.

Affected packages and fixed versions:
- envoy (Bitnami): affected all versions; fixed in 1.33.10, 1.34.9, 1.35.5, 1.36.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62409/ (Markdown: https://insights.sbomify.com/CVE-2025-62409/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62409
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62409
- OSV: https://osv.dev/vulnerability/CVE-2025-62409

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62409/
Summaries are generated and may contain mistakes; the official description above is the record.
