{"answers":{"affected":"2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62412 exists.","fix":"Upgrade librenms/librenms to 25.10.0 or later.","what":"CVE-2025-62412 is a low-severity cross-site scripting vulnerability in Librenms Librenms, published on 16 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62412 and fix it if it is affected.\n\nWhat it is: CVE-2025-62412 is a low-severity cross-site scripting vulnerability in Librenms Librenms, published on 16 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62412 exists.\n\nAffected packages and fixed versions:\n- librenms/librenms (Packagist): affected all versions; fixed in 25.10.0\n- librenms/librenms (Packagist): affected all versions; fixed in 25.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62412/ (Markdown: https://insights.sbomify.com/CVE-2025-62412/index.md)","id":"CVE-2025-62412","markdown":"https://insights.sbomify.com/CVE-2025-62412/index.md","name":"CVE-2025-62412","record":{"aliases":["GHSA-6g2v-66ch-6xmh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Network monitoring system","requires_auth":"high_privilege","summary":"Attackers can inject malicious HTML into alert rule names in LibreNMS, potentially leading to session hijacking or code execution.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"librenms","vendor":"librenms"}],"cvss":{"score":3.8,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"LibreNMS  is a community-based GPL-licensed network monitoring system. The alert rule name in the Alerts \u003e Alert Rules page is not properly sanitized, and can be used to inject HTML code. This vulnerability is fixed in 25.10.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"LibreNMS alert-rules Cross-Site Scripting Vulnerability","id":"CVE-2025-62412","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"librenms:librenms","products":["librenms:librenms"],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"MQTTX vulnerable to cross-site scripting via improper message payload rendering","id":"CVE-2025-62413"},"packages":[{"ecosystem":"Packagist","fixed":["25.10.0"],"introduced":["0"],"last_affected":[],"package":"librenms/librenms","purl":null,"source":"GHSA-6g2v-66ch-6xmh"},{"ecosystem":"Packagist","fixed":["25.10.0"],"introduced":["0"],"last_affected":[],"package":"librenms/librenms","purl":"pkg:composer/librenms/librenms","source":"GHSA-6g2v-66ch-6xmh"}],"prev":{"headline":"Stored XSS in Alert Transport name field in LibreNMS","id":"CVE-2025-62411"},"products":["librenms"],"published":"2025-10-16","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in librenms/librenms","id":"CVE-2023-4982","kev_date_added":null,"published":"2023-09-15"},{"cvss_score":9.8,"headline":"Command injection in librenms","id":"CVE-2022-29712","kev_date_added":null,"published":"2022-05-31"},{"cvss_score":9.8,"headline":"Path traversal in librenms/librenms","id":"CVE-2021-44278","kev_date_added":null,"published":"2021-12-03"},{"cvss_score":9.8,"headline":"LibreNMS Information Disclosure","id":"CVE-2019-10665","kev_date_added":null,"published":"2019-09-09"},{"cvss_score":9.8,"headline":"LibreNMS arbitrary OS commands execution","id":"CVE-2018-20434","kev_date_added":null,"published":"2019-04-24"},{"cvss_score":9.3,"headline":"LibreNMS: SQL Injection in ajax_table.php spreads through a covert data stream","id":"CVE-2026-26988","kev_date_added":null,"published":"2026-02-20"},{"cvss_score":9.2,"headline":"LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion","id":"CVE-2026-86426","kev_date_added":null,"published":"2026-09-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-16","vendors":["librenms"]},"summary":"Attackers can inject malicious HTML into alert rule names in LibreNMS, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2025-62412/"}