# CVE-2025-62414: bagisto - Cross Site Scripting (XSS) in Create New Customer

> An attacker with admin access can inject malicious scripts into customer creation fields, potentially stealing sessions or executing admin actions.

- **Severity:** Medium 6.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Oct 2025
- **Updated:** 17 Oct 2025
- **Also known as:** GHSA-r9xj-mvqf-jm7w

## What is CVE-2025-62414?

CVE-2025-62414 is a medium-severity cross-site scripting vulnerability in bagisto, published on 16 Oct 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Bagisto is an open source laravel eCommerce platform. In Bagisto v2.3.7, the “Create New Customer” feature (in the admin panel) is vulnerable to Cross-Site Scripting (XSS). An attacker with access to the admin create-customer form can inject malicious JavaScript payloads into certain input fields. These payloads may later execute in the context of an admin’s browser or another user viewing the customer data, enabling session theft or admin-level actions. This vulnerability is fixed in 2.3.8.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-87 (Improper Neutralization of Alternate XSS Syntax), CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2025-62414?

2 open source packages ship an affected version, including bagisto/bagisto. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bagisto/bagisto` | Packagist | All versions | 2.3.8 |
| `bagisto/bagisto` | Packagist | All versions | 2.3.8 |

Products: Webkul Bagisto.

## How do I fix CVE-2025-62414?

Upgrade bagisto/bagisto to 2.3.8 or later.

## Is CVE-2025-62414 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62414 exists.

## Other vulnerabilities in bagisto

- [CVE-2026-21448](https://insights.sbomify.com/CVE-2026-21448/): Bagisto has Normal & Blind SSTI from low-privilege user when ordering product (high 8.9)
- [CVE-2026-21446](https://insights.sbomify.com/CVE-2026-21446/): Bagisto Missing Authentication on Installer API Endpoints (high 8.8)
- [CVE-2023-36237](https://insights.sbomify.com/CVE-2023-36237/): Bagisto Cross-Site Request Forgery vulnerability (high 8.8)
- [CVE-2023-33570](https://insights.sbomify.com/CVE-2023-33570/): Code injection in n/a (high 8.8)
- [CVE-2019-16403](https://insights.sbomify.com/CVE-2019-16403/): Authorization Bypass Through User-Controlled Key in Bagisto (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62414 and fix it if it is affected.

What it is: CVE-2025-62414 is a medium-severity cross-site scripting vulnerability in bagisto, published on 16 Oct 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62414 exists.

Affected packages and fixed versions:
- bagisto/bagisto (Packagist): affected all versions; fixed in 2.3.8
- bagisto/bagisto (Packagist): affected all versions; fixed in 2.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62414/ (Markdown: https://insights.sbomify.com/CVE-2025-62414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62414
- OSV: https://osv.dev/vulnerability/CVE-2025-62414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62414/
Summaries are generated and may contain mistakes; the official description above is the record.
