CVE-2025-62415 bagisto - Cross Site Scripting (XSS) in TinyMCE Image Upload (HTML)

Medium 6.9 Published Updated

An attacker with admin privileges can upload malicious HTML files via TinyMCE, leading to script execution in other users' browsers.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-62415?

CVE-2025-62415 is a medium-severity cross-site scripting vulnerability in bagisto, published on 16 Oct 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Bagisto is an open source laravel eCommerce platform. In Bagisto v2.3.7, the TinyMCE image upload functionality allows an attacker with sufficient privileges (e.g. admin) to upload a crafted HTML file containing embedded JavaScript. When viewed, the malicious code executes in the context of the admin/user’s browser. This vulnerability is fixed in 2.3.8.

Weakness: CWE-87, CWE-80

Which versions are affected by CVE-2025-62415?

2 open source packages ship an affected version, including bagisto/bagisto. It affects 1 product.

PackageAffectedFixed in
bagisto/bagisto PackagistAll versions2.3.8
bagisto/bagisto PackagistAll versions2.3.8

Products include Webkul Bagisto.

How do I fix CVE-2025-62415?

Upgrade bagisto/bagisto to 2.3.8 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-62415 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62415 exists.

Sources

Also known as GHSA-67px-r26w-598x.

Is CVE-2025-62415 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free