CVE-2025-62416 bagisto - Server Side Template Injection (SSTI) in Product Description

Medium 5.1 Published Updated

An attacker with product creation privileges can inject template expressions to achieve remote code execution on the server.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-62416?

CVE-2025-62416 is a medium-severity code injection vulnerability in bagisto, published on 16 Oct 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Bagisto is an open source laravel eCommerce platform. Bagisto v2.3.7 is vulnerable to Server-Side Template Injection (SSTI) due to unsanitized user input being processed by the server-side templating engine when rendering product descriptions. This allows an attacker with product creation privileges to inject arbitrary template expressions that are evaluated by the backend — potentially leading to Remote Code Execution (RCE) on the server. This vulnerability is fixed in 2.3.8.

Weakness: CWE-94, CWE-1336

Which versions are affected by CVE-2025-62416?

2 open source packages ship an affected version, including bagisto/bagisto. It affects 1 product.

PackageAffectedFixed in
bagisto/bagisto PackagistAll versions2.3.8
bagisto/bagisto PackagistAll versions2.3.8

Products include Webkul Bagisto.

How do I fix CVE-2025-62416?

Upgrade bagisto/bagisto to 2.3.8 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2025-62416 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62416 exists.

Sources

Also known as GHSA-527q-4wqv-g9wj.

Is CVE-2025-62416 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free