{"answers":{"affected":"3 open source packages ship an affected version, including vllm.","exploited":"There is no known exploitation of CVE-2025-6242 in the wild and no public exploit code.","fix":"Upgrade vllm to 0.11.0 or later.","what":"CVE-2025-6242 is a high-severity server-side request forgery vulnerability in Red Hat AI Inference Server, published on 7 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-6242 and fix it if it is affected.\n\nWhat it is: CVE-2025-6242 is a high-severity server-side request forgery vulnerability in Red Hat AI Inference Server, published on 7 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-6242 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.5.0; fixed in 0.11.0\n- vllm (PyPI): affected from 0.5.0; fixed in 0.11.0\n- vllm (PyPI): affected from 0.5.0; fixed in 0.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-6242/ (Markdown: https://insights.sbomify.com/CVE-2025-6242/index.md)","id":"CVE-2025-6242","markdown":"https://insights.sbomify.com/CVE-2025-6242/index.md","name":"CVE-2025-6242","record":{"aliases":["GHSA-3f6c-7fw2-ppm4","PYSEC-2026-2011"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"vLLM inference server","requires_auth":"low_privilege","summary":"Attackers can force the vLLM server to make arbitrary requests to internal network resources via user-provided URLs in the MediaConnector class.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"A Server-Side Request Forgery (SSRF) vulnerability exists in the MediaConnector class within the vLLM project's multimodal feature set. The load_from_url and load_from_url_async methods fetch and process media from user-provided URLs without adequate restrictions on the target hosts. This allows an attacker to coerce the vLLM server into making arbitrary requests to internal network resources.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Vllm: server side request forgery (ssrf) in mediaconnector","id":"CVE-2025-6242","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Cross-site scripting in Essential Addons for Elementor – Popular Elementor Templates \u0026 Widgets","id":"CVE-2025-6244"},"packages":[{"ecosystem":"PyPI","fixed":["0.11.0"],"introduced":["0.5.0"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-3f6c-7fw2-ppm4"},{"ecosystem":"PyPI","fixed":["0.11.0"],"introduced":["0.5.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-3f6c-7fw2-ppm4"},{"ecosystem":"PyPI","fixed":["0.11.0"],"introduced":["0.5.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2026-2011"}],"prev":{"headline":"CVE-2025-6241","id":"CVE-2025-6241"},"products":["Red Hat AI Inference Server","Red Hat Enterprise Linux AI (RHEL AI)"],"published":"2025-10-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-17","vendors":["Red Hat"]},"summary":"Attackers can force the vLLM server to make arbitrary requests to internal network resources via user-provided URLs in the MediaConnector class.","url":"https://insights.sbomify.com/CVE-2025-6242/"}