# CVE-2025-6242: Vllm: server side request forgery (ssrf) in mediaconnector

> Attackers can force the vLLM server to make arbitrary requests to internal network resources via user-provided URLs in the MediaConnector class.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2025
- **Updated:** 17 Oct 2025
- **Also known as:** GHSA-3f6c-7fw2-ppm4, PYSEC-2026-2011

## What is CVE-2025-6242?

CVE-2025-6242 is a high-severity server-side request forgery vulnerability in Red Hat AI Inference Server, published on 7 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A Server-Side Request Forgery (SSRF) vulnerability exists in the MediaConnector class within the vLLM project's multimodal feature set. The load_from_url and load_from_url_async methods fetch and process media from user-provided URLs without adequate restrictions on the target hosts. This allows an attacker to coerce the vLLM server into making arbitrary requests to internal network resources.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-6242?

3 open source packages ship an affected version, including vllm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.5.0 | 0.11.0 |
| `vllm` | PyPI | From 0.5.0 | 0.11.0 |
| `vllm` | PyPI | From 0.5.0 | 0.11.0 |

## How do I fix CVE-2025-6242?

Upgrade vllm to 0.11.0 or later.

## Is CVE-2025-6242 being exploited?

There is no known exploitation of CVE-2025-6242 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6242 and fix it if it is affected.

What it is: CVE-2025-6242 is a high-severity server-side request forgery vulnerability in Red Hat AI Inference Server, published on 7 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-6242 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.5.0; fixed in 0.11.0
- vllm (PyPI): affected from 0.5.0; fixed in 0.11.0
- vllm (PyPI): affected from 0.5.0; fixed in 0.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6242/ (Markdown: https://insights.sbomify.com/CVE-2025-6242/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6242
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6242
- OSV: https://osv.dev/vulnerability/CVE-2025-6242

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6242/
Summaries are generated and may contain mistakes; the official description above is the record.
