# CVE-2025-62421: DataEase vulnerable to stored cross-site scripting via file upload bypass

> Attackers can upload malicious HTML files via a bypassed authentication check, leading to stored cross-site scripting in DataEase.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Oct 2025
- **Updated:** 17 Oct 2025
- **Also known as:** GHSA-2wmv-rr3p-pf43

## What is CVE-2025-62421?

CVE-2025-62421 is a medium-severity cross-site scripting vulnerability in Dataease Dataease, published on 17 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DataEase is a data visualization and analytics platform. In DataEase versions through 2.10.13, a stored cross-site scripting vulnerability exists due to improper file upload validation and authentication bypass. The StaticResourceApi interface defines a route upload/{fileId} that uses a URL path parameter where both the filename and extension of uploaded files are controllable by users. During permission validation, the TokenFilter invokes the WhitelistUtils#match method to determine if the URL path is in the allowlist. If the requestURI ends with .js or similar extensions, it is directly deemed safe and bypasses permission checks. This allows an attacker to access "upload/1.js" while specifying arbitrary file extensions, enabling the upload of HTML files containing malicious JavaScript. The vulnerability is fixed in version 2.10.14. No known workarounds exist.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-62421?

It affects 1 product.


Products: Dataease Dataease.

## How do I fix CVE-2025-62421?

No fix has been published for CVE-2025-62421 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-62421 being exploited?

There is no known exploitation of CVE-2025-62421 in the wild and no public exploit code.

## Other vulnerabilities in Dataease Dataease

- [CVE-2024-57707](https://insights.sbomify.com/CVE-2024-57707/): Code injection in n/a (critical 9.8)
- [CVE-2024-46997](https://insights.sbomify.com/CVE-2024-46997/): DataEase's H2 datasource has a remote command execution risk (critical 9.8)
- [CVE-2023-33963](https://insights.sbomify.com/CVE-2023-33963/): DataEase data source has deserialization vulnerability (critical 9.8)
- [CVE-2023-28437](https://insights.sbomify.com/CVE-2023-28437/): SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed (critical 9.8)
- [CVE-2022-39312](https://insights.sbomify.com/CVE-2022-39312/): Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62421 and fix it if it is affected.

What it is: CVE-2025-62421 is a medium-severity cross-site scripting vulnerability in Dataease Dataease, published on 17 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62421 in the wild and no public exploit code.

Affected product: Dataease Dataease. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62421/ (Markdown: https://insights.sbomify.com/CVE-2025-62421/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62421
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62421
- OSV: https://osv.dev/vulnerability/CVE-2025-62421

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62421/
Summaries are generated and may contain mistakes; the official description above is the record.
