CVE-2025-62422 DataEase SQL injection vulnerability

High 8.7 Published Updated

Attackers can execute arbitrary SQL commands via the tableName parameter in the tableField interface, compromising data integrity and confidentiality.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-62422?

CVE-2025-62422 is a high-severity SQL injection vulnerability in Dataease Dataease, published on 17 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

DataEase is an open source data visualization and analytics platform. In versions 2.10.13 and earlier, the /de2api/datasetData/tableField interface is vulnerable to SQL injection. An attacker can construct a malicious tableName parameter to execute arbitrary SQL commands. This issue is fixed in version 2.10.14. No known workarounds exist.

Weakness: CWE-89

Which versions are affected by CVE-2025-62422?

It affects 1 product.

Products include Dataease Dataease.

How do I fix CVE-2025-62422?

No fix has been published for CVE-2025-62422 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2025-62422 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62422 exists.

All Dataease Dataease vulnerabilities

Sources

Also known as GHSA-54m5-xrw4-mv36.

Is CVE-2025-62422 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free