# CVE-2025-62426: vLLM vulnerable to DoS via large Chat Completion or Tokenization requests with specially crafted `chat_template_kwargs`

> Attackers can cause denial of service in vLLM by sending specially crafted chat_template_kwargs to chat or tokenization endpoints, blocking server processing.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2025
- **Updated:** 24 Nov 2025
- **Also known as:** GHSA-69j4-grxj-j64p, PYSEC-2026-2012

## What is CVE-2025-62426?

CVE-2025-62426 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 21 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, the /v1/chat/completions and /tokenize endpoints allow a chat_template_kwargs request parameter that is used in the code before it is properly validated against the chat template. With the right chat_template_kwargs parameters, it is possible to block processing of the API server for long periods of time, delaying all other requests. This issue has been patched in version 0.11.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-62426?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.5.5 | 0.11.1 |
| `vllm` | PyPI | From 0.5.5 | 0.11.1 |
| `vllm` | PyPI | From 0.5.5 | 0.11.1 |

Products: Vllm Vllm.

## How do I fix CVE-2025-62426?

Upgrade vllm to 0.11.1 or later.

## Is CVE-2025-62426 being exploited?

There is no known exploitation of CVE-2025-62426 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62426 and fix it if it is affected.

What it is: CVE-2025-62426 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 21 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62426 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.5.5; fixed in 0.11.1
- vllm (PyPI): affected from 0.5.5; fixed in 0.11.1
- vllm (PyPI): affected from 0.5.5; fixed in 0.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62426/ (Markdown: https://insights.sbomify.com/CVE-2025-62426/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62426
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62426
- OSV: https://osv.dev/vulnerability/CVE-2025-62426

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62426/
Summaries are generated and may contain mistakes; the official description above is the record.
