CVE-2025-62427 Server-Side Request Forgery (SSRF) in Angular SSR

High 8.7 Published Updated

Attackers can force Angular SSR servers to make requests to arbitrary external domains by manipulating URL paths, potentially exposing internal data or bypassing security controls.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-62427?

CVE-2025-62427 is a high-severity server-side request forgery vulnerability in angular-cli, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Angular SSR is a server-rise rendering tool for Angular applications. The vulnerability is a Server-Side Request Forgery (SSRF) flaw within the URL resolution mechanism of Angular's Server-Side Rendering package (@angular/ssr) before 19.2.18, 20.3.6, and 21.0.0-next.8. The function createRequestUrl uses the native URL constructor. When an incoming request path (e.g., originalUrl or url) begins with a double forward slash (//) or backslash (\\), the URL constructor treats it as a schema-relative URL. This behavior overrides the security-intended base URL (protocol, host, and port) supplied as the second argument, instead resolving the URL against the scheme of the base URL but adopting the attacker-controlled hostname. This allows an attacker to specify an external domain in the URL path, tricking the Angular SSR environment into setting the page's virtual location (accessible via DOCUMENT or PlatformLocation tokens) to this attacker-controlled domain. Any subsequent relative HTTP requests made during the SSR process (e.g., using HttpClient.get('assets/data.json')) will be incorrectly resolved against the attacker's domain, forcing the server to communicate with an arbitrary external endpoint. This vulnerability is fixed in 19.2.18, 20.3.6, and 21.0.0-next.8.

Weakness: CWE-918

Which versions are affected by CVE-2025-62427?

6 open source packages ship an affected version, including @angular/ssr.

PackageAffectedFixed in
@angular/ssr npmFrom 19.0.0-next.019.2.18
@angular/ssr npmFrom 19.0.0-next.019.2.18
@angular/ssr npmFrom 20.0.0-next.020.3.6
@angular/ssr npmFrom 20.0.0-next.020.3.6
@angular/ssr npmFrom 21.0.0-next.021.0.0-next.8
@angular/ssr npmFrom 21.0.0-next.021.0.0-next.8

How do I fix CVE-2025-62427?

Upgrade @angular/ssr to a fixed version for your release line: 19.2.18, 20.3.6 or 21.0.0-next.8.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2025-62427 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62427 exists.

Sources

Also known as GHSA-q63q-pgmf-mxhr.

Is CVE-2025-62427 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free