# CVE-2025-62430: ClipBucket v5 stored XSS via video/photo fields

> Attackers can inject malicious scripts into video or photo metadata fields, allowing execution in victim browsers to steal data or perform actions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 17 Oct 2025
- **Updated:** 17 Oct 2025
- **Also known as:** GHSA-qrqq-hpf3-9mc9

## What is CVE-2025-62430?

CVE-2025-62430 is a medium-severity cross-site scripting vulnerability in MacWarrior clipbucket-v5, published on 17 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ClipBucket v5 is an open source video sharing platform. ClipBucket v5 through build 5.5.2 #145 allows stored cross-site scripting (XSS) in multiple video and photo metadata fields. For videos the Tags field and the Genre, Actors, Producer, Executive Producer, and Director fields in Movieinfos accept user supplied values without adequate sanitization. For photos the Photo Title and Photo Tags fields accept user supplied values without adequate sanitization. A regular user who can edit a video or photo can inject script (for example by supplying a value such as a closing delimiter followed by a script element). The injected script executes when any user, including an unauthenticated visitor or an administrator, views the affected video or photo page. Although cookies are set with the HttpOnly attribute and cannot be read directly, the injected script can issue fetch requests to endpoints such as admin_area pages and exfiltrate their contents or trigger unintended actions. Version 5.5.2 build #146 and later contain a fix. Update to build 5.5.2 #146 or later. No known workarounds exist.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-62430?

It affects 1 product.


Products: Oxygenz Clipbucket.

## How do I fix CVE-2025-62430?

No fix has been published for CVE-2025-62430 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-62430 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62430 exists.

## Other vulnerabilities in MacWarrior clipbucket-v5

- [CVE-2026-21875](https://insights.sbomify.com/CVE-2026-21875/): ClipBucket v5 Vulnerable to Blind SQL Injection through Channel Comments (critical 9.8)
- [CVE-2025-67418](https://insights.sbomify.com/CVE-2025-67418/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2025-21624](https://insights.sbomify.com/CVE-2025-21624/): ClipBucket V5 Playlist Cover File Upload to Remote Code Execution (critical 9.8)
- [CVE-2024-54135](https://insights.sbomify.com/CVE-2024-54135/): Untrusted Deserialization in ClipBucket-v5 Version 2.0 to 5.5.1 Revision 199 (critical 9.8)
- [CVE-2024-54136](https://insights.sbomify.com/CVE-2024-54136/): Untrusted Deserialization in ClipBucket-v5 Version 5.5.1 Revision 199 and Below (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62430 and fix it if it is affected.

What it is: CVE-2025-62430 is a medium-severity cross-site scripting vulnerability in MacWarrior clipbucket-v5, published on 17 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62430 exists.

Affected product: MacWarrior clipbucket-v5. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62430/ (Markdown: https://insights.sbomify.com/CVE-2025-62430/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62430
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62430
- OSV: https://osv.dev/vulnerability/CVE-2025-62430

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62430/
Summaries are generated and may contain mistakes; the official description above is the record.
