# CVE-2025-62504: Envoy Lua filter use-after-free when oversized rewritten response body causes crash

> A use-after-free in Envoy's Lua filter causes a crash when a rewritten response body exceeds buffer limits, leading to denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2025
- **Updated:** 17 Oct 2025
- **Also known as:** BIT-envoy-2025-62504, GHSA-gcxr-6vrp-wff3

## What is CVE-2025-62504?

CVE-2025-62504 is a medium-severity use after free vulnerability in Envoyproxy Envoy, published on 16 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Envoy is an open source edge and service proxy. Envoy versions earlier than 1.36.2, 1.35.6, 1.34.10, and 1.33.12 contain a use-after-free vulnerability in the Lua filter. When a Lua script executing in the response phase rewrites a response body so that its size exceeds the configured per_connection_buffer_limit_bytes (default 1MB), Envoy generates a local reply whose headers override the original response headers, leaving dangling references and causing a crash. This results in denial of service. Updating to versions 1.36.2, 1.35.6, 1.34.10, or 1.33.12 fixes the issue. Increasing per_connection_buffer_limit_bytes (and for HTTP/2 the initial_stream_window_size) or increasing per_request_buffer_limit_bytes / request_body_buffer_limit can reduce the likelihood of triggering the condition but does not correct the underlying memory safety flaw.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2025-62504?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | All versions | 1.33.12, 1.34.10, 1.35.6, 1.36.2 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2025-62504?

Upgrade envoy to a fixed version for your release line: 1.33.12, 1.34.10, 1.35.6 or 1.36.2.

## Is CVE-2025-62504 being exploited?

There is no known exploitation of CVE-2025-62504 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62504 and fix it if it is affected.

What it is: CVE-2025-62504 is a medium-severity use after free vulnerability in Envoyproxy Envoy, published on 16 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62504 in the wild and no public exploit code.

Affected packages and fixed versions:
- envoy (Bitnami): affected all versions; fixed in 1.33.12, 1.34.10, 1.35.6, 1.36.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62504/ (Markdown: https://insights.sbomify.com/CVE-2025-62504/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62504
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62504
- OSV: https://osv.dev/vulnerability/CVE-2025-62504

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62504/
Summaries are generated and may contain mistakes; the official description above is the record.
