CVE-2025-62505 SSRF in lobehub/lobe-chat with native web fetch module

Low 3.0 Published Updated

An attacker can exploit an SSRF vulnerability in LobeChat to access internal network resources and cloud metadata via the web crawler endpoint.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-62505?

CVE-2025-62505 is a low-severity server-side request forgery vulnerability in lobehub lobe-chat, published on 17 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

LobeChat is an open source chat application platform. The web-crawler package in LobeChat version 1.136.1 allows server-side request forgery (SSRF) in the tools.search.crawlPages tRPC endpoint. A client can supply an arbitrary urls array together with impls containing the value naive. The service passes the user URLs to Crawler.crawl and the naive implementation performs a server-side fetch of each supplied URL without validating or restricting internal network addresses (such as localhost, 127.0.0.1, private IP ranges, or cloud instance metadata endpoints). This allows an attacker with a valid user token (or in development mode using a bypass header) to make the server disclose responses from internal HTTP services, potentially exposing internal API data or cloud metadata credentials. Version 1.136.2 fixes the issue. Update to version 1.136.2. No known workarounds exist.

Weakness: CWE-918

Which versions are affected by CVE-2025-62505?

2 open source packages ship an affected version, including @lobehub/chat.

PackageAffectedFixed in
@lobehub/chat npmAll versions1.136.2
@lobehub/chat npmAll versions1.136.2

How do I fix CVE-2025-62505?

Upgrade @lobehub/chat to 1.136.2 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2025-62505 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62505 exists.

Sources

Also known as GHSA-fgx4-p8xf-qhp9.

Is CVE-2025-62505 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free