{"answers":{"affected":"2 open source packages ship an affected version, including @lobehub/chat.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62505 exists.","fix":"Upgrade @lobehub/chat to 1.136.2 or later.","what":"CVE-2025-62505 is a low-severity server-side request forgery vulnerability in lobehub lobe-chat, published on 17 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62505 and fix it if it is affected.\n\nWhat it is: CVE-2025-62505 is a low-severity server-side request forgery vulnerability in lobehub lobe-chat, published on 17 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62505 exists.\n\nAffected packages and fixed versions:\n- @lobehub/chat (npm): affected all versions; fixed in 1.136.2\n- @lobehub/chat (npm): affected all versions; fixed in 1.136.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62505/ (Markdown: https://insights.sbomify.com/CVE-2025-62505/index.md)","id":"CVE-2025-62505","markdown":"https://insights.sbomify.com/CVE-2025-62505/index.md","name":"CVE-2025-62505","record":{"aliases":["GHSA-fgx4-p8xf-qhp9"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LobeChat chat platform","requires_auth":"high_privilege","summary":"An attacker can exploit an SSRF vulnerability in LobeChat to access internal network resources and cloud metadata via the web crawler endpoint.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"LobeChat is an open source chat application platform. The web-crawler package in LobeChat version 1.136.1 allows server-side request forgery (SSRF) in the tools.search.crawlPages tRPC endpoint. A client can supply an arbitrary urls array together with impls containing the value naive. The service passes the user URLs to Crawler.crawl and the naive implementation performs a server-side fetch of each supplied URL without validating or restricting internal network addresses (such as localhost, 127.0.0.1, private IP ranges, or cloud instance metadata endpoints). This allows an attacker with a valid user token (or in development mode using a bypass header) to make the server disclose responses from internal HTTP services, potentially exposing internal API data or cloud metadata credentials. Version 1.136.2 fixes the issue. Update to version 1.136.2. No known workarounds exist.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"SSRF in lobehub/lobe-chat with native web fetch module","id":"CVE-2025-62505","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"MinIO vulnerable to privilege escalation via session policy bypass in service accounts and STS","id":"CVE-2025-62506"},"packages":[{"ecosystem":"npm","fixed":["1.136.2"],"introduced":["0"],"last_affected":[],"package":"@lobehub/chat","purl":null,"source":"GHSA-fgx4-p8xf-qhp9"},{"ecosystem":"npm","fixed":["1.136.2"],"introduced":["0"],"last_affected":[],"package":"@lobehub/chat","purl":"pkg:npm/%40lobehub/chat","source":"GHSA-fgx4-p8xf-qhp9"}],"prev":{"headline":"Envoy Lua filter use-after-free when oversized rewritten response body causes crash","id":"CVE-2025-62504"},"products":["lobe-chat"],"published":"2025-10-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-17","vendors":["lobehub"]},"summary":"An attacker can exploit an SSRF vulnerability in LobeChat to access internal network resources and cloud metadata via the web crawler endpoint.","url":"https://insights.sbomify.com/CVE-2025-62505/"}