{"answers":{"affected":"2 open source packages ship an affected version, including starcitizentools/citizen-skin.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62508 exists.","fix":"Upgrade starcitizentools/citizen-skin to 3.9.0 or later.","what":"CVE-2025-62508 is a medium-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-skins-Citizen, published on 17 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62508 and fix it if it is affected.\n\nWhat it is: CVE-2025-62508 is a medium-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-skins-Citizen, published on 17 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62508 exists.\n\nAffected packages and fixed versions:\n- starcitizentools/citizen-skin (Packagist): affected from 3.3.0; fixed in 3.9.0\n- starcitizentools/citizen-skin (Packagist): affected from 3.3.0; fixed in 3.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62508/ (Markdown: https://insights.sbomify.com/CVE-2025-62508/index.md)","id":"CVE-2025-62508","markdown":"https://insights.sbomify.com/CVE-2025-62508/index.md","name":"CVE-2025-62508","record":{"aliases":["GHSA-g955-vw6w-v6pp"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki skin","requires_auth":"high_privilege","summary":"A user with interface editing rights can inject arbitrary JavaScript into the sticky header, allowing session hijacking and data theft in MediaWiki.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. Citizen from 3.3.0 to 3.9.0 are vulnerable to stored cross-site scripting in the sticky header button message handling. In stickyHeader.js the copyButtonAttributes function assigns innerHTML from a source element’s textContent when copying button labels. This causes escaped HTML in system message content (such as citizen-share, citizen-view-history, citizen-view-edit, and nstab-talk) to be interpreted as HTML in the sticky header, allowing injection of arbitrary script by a user with the ability to edit interface messages. The vulnerability allows a user with the editinterface right but without the editsitejs right (by default the sysop group has editinterface but may not have editsitejs) to execute arbitrary JavaScript in other users’ sessions, enabling unauthorized access to sensitive data or actions. The issue is fixed in 3.9.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Citizen vulnerable to stored XSS in sticky header button messages","id":"CVE-2025-62508","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"FileRise improper ownership/permission validation allowed cross-tenant file operations","id":"CVE-2025-62509"},"packages":[{"ecosystem":"Packagist","fixed":["3.9.0"],"introduced":["3.3.0"],"last_affected":[],"package":"starcitizentools/citizen-skin","purl":null,"source":"GHSA-g955-vw6w-v6pp"},{"ecosystem":"Packagist","fixed":["3.9.0"],"introduced":["3.3.0"],"last_affected":[],"package":"starcitizentools/citizen-skin","purl":"pkg:composer/starcitizentools/citizen-skin","source":"GHSA-g955-vw6w-v6pp"}],"prev":{"headline":"Redis: Bug in XACKDEL may lead to stack overflow and potential RCE","id":"CVE-2025-62507"},"products":["mediawiki-skins-Citizen"],"published":"2025-10-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-17","vendors":["StarCitizenTools"]},"summary":"A user with interface editing rights can inject arbitrary JavaScript into the sticky header, allowing session hijacking and data theft in MediaWiki.","url":"https://insights.sbomify.com/CVE-2025-62508/"}