# CVE-2025-62508: Citizen vulnerable to stored XSS in sticky header button messages

> A user with interface editing rights can inject arbitrary JavaScript into the sticky header, allowing session hijacking and data theft in MediaWiki.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Oct 2025
- **Updated:** 17 Oct 2025
- **Also known as:** GHSA-g955-vw6w-v6pp

## What is CVE-2025-62508?

CVE-2025-62508 is a medium-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-skins-Citizen, published on 17 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. Citizen from 3.3.0 to 3.9.0 are vulnerable to stored cross-site scripting in the sticky header button message handling. In stickyHeader.js the copyButtonAttributes function assigns innerHTML from a source element’s textContent when copying button labels. This causes escaped HTML in system message content (such as citizen-share, citizen-view-history, citizen-view-edit, and nstab-talk) to be interpreted as HTML in the sticky header, allowing injection of arbitrary script by a user with the ability to edit interface messages. The vulnerability allows a user with the editinterface right but without the editsitejs right (by default the sysop group has editinterface but may not have editsitejs) to execute arbitrary JavaScript in other users’ sessions, enabling unauthorized access to sensitive data or actions. The issue is fixed in 3.9.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-62508?

2 open source packages ship an affected version, including starcitizentools/citizen-skin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `starcitizentools/citizen-skin` | Packagist | From 3.3.0 | 3.9.0 |
| `starcitizentools/citizen-skin` | Packagist | From 3.3.0 | 3.9.0 |

## How do I fix CVE-2025-62508?

Upgrade starcitizentools/citizen-skin to 3.9.0 or later.

## Is CVE-2025-62508 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62508 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62508 and fix it if it is affected.

What it is: CVE-2025-62508 is a medium-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-skins-Citizen, published on 17 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62508 exists.

Affected packages and fixed versions:
- starcitizentools/citizen-skin (Packagist): affected from 3.3.0; fixed in 3.9.0
- starcitizentools/citizen-skin (Packagist): affected from 3.3.0; fixed in 3.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62508/ (Markdown: https://insights.sbomify.com/CVE-2025-62508/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62508
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62508
- OSV: https://osv.dev/vulnerability/CVE-2025-62508

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62508/
Summaries are generated and may contain mistakes; the official description above is the record.
