CVE-2025-62517 Rollbar.js Prototype Pollution Vulnerability in merge()

Medium 5.9 Published Updated

Prototype pollution in Rollbar.js merge() allows attackers to manipulate object prototypes if untrusted input is passed to configure().

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-62517?

CVE-2025-62517 is a medium-severity vulnerability in rollbar.js, published on 23 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Rollbar.js offers error tracking and logging from Javascript to Rollbar. In versions before 2.26.5 and from 3.0.0-alpha1 to before 3.0.0-beta5, there is a prototype pollution vulnerability in merge(). If application code calls rollbar.configure() with untrusted input, prototype pollution is possible. This issue has been fixed in versions 2.26.5 and 3.0.0-beta5. A workaround involves ensuring that values passed to rollbar.configure() do not contain untrusted input.

Weakness: CWE-1321

Which versions are affected by CVE-2025-62517?

4 open source packages ship an affected version, including rollbar.

PackageAffectedFixed in
rollbar npmAll versions2.26.5
rollbar npmAll versions2.26.5
rollbar npmFrom 3.0.0-alpha13.0.0-beta5
rollbar npmFrom 3.0.0-alpha13.0.0-beta5

How do I fix CVE-2025-62517?

Upgrade rollbar to a fixed version for your release line: 2.26.5 or 3.0.0-beta5.

Is CVE-2025-62517 being exploited?

There is no known exploitation of CVE-2025-62517 in the wild and no public exploit code.

Sources

Also known as GHSA-xcg2-9pp4-j82x.

Is CVE-2025-62517 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free