# CVE-2025-62517: Rollbar.js Prototype Pollution Vulnerability in merge()

> Prototype pollution in Rollbar.js merge() allows attackers to manipulate object prototypes if untrusted input is passed to configure().

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Oct 2025
- **Updated:** 23 Oct 2025
- **Also known as:** GHSA-xcg2-9pp4-j82x

## What is CVE-2025-62517?

CVE-2025-62517 is a medium-severity vulnerability in rollbar.js, published on 23 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rollbar.js offers error tracking and logging from Javascript to Rollbar. In versions before 2.26.5 and from 3.0.0-alpha1 to before 3.0.0-beta5, there is a prototype pollution vulnerability in merge(). If application code calls rollbar.configure() with untrusted input, prototype pollution is possible. This issue has been fixed in versions 2.26.5 and 3.0.0-beta5. A workaround involves ensuring that values passed to rollbar.configure() do not contain untrusted input.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2025-62517?

4 open source packages ship an affected version, including rollbar.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rollbar` | npm | All versions | 2.26.5 |
| `rollbar` | npm | All versions | 2.26.5 |
| `rollbar` | npm | From 3.0.0-alpha1 | 3.0.0-beta5 |
| `rollbar` | npm | From 3.0.0-alpha1 | 3.0.0-beta5 |

## How do I fix CVE-2025-62517?

Upgrade rollbar to a fixed version for your release line: 2.26.5 or 3.0.0-beta5.

## Is CVE-2025-62517 being exploited?

There is no known exploitation of CVE-2025-62517 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62517 and fix it if it is affected.

What it is: CVE-2025-62517 is a medium-severity vulnerability in rollbar.js, published on 23 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62517 in the wild and no public exploit code.

Affected packages and fixed versions:
- rollbar (npm): affected all versions; fixed in 2.26.5
- rollbar (npm): affected all versions; fixed in 2.26.5
- rollbar (npm): affected from 3.0.0-alpha1; fixed in 3.0.0-beta5
- rollbar (npm): affected from 3.0.0-alpha1; fixed in 3.0.0-beta5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62517/ (Markdown: https://insights.sbomify.com/CVE-2025-62517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62517
- OSV: https://osv.dev/vulnerability/CVE-2025-62517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62517/
Summaries are generated and may contain mistakes; the official description above is the record.
