CVE-2025-62518 astral-tokio-tar Vulnerable to PAX Header Desynchronization
Attackers can smuggle archive entries by exploiting PAX header parsing flaws in the astral-tokio-tar Rust library, potentially leading to data exposure or logic errors.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-62518?
CVE-2025-62518 is a high-severity vulnerability in astral-sh tokio-tar, published on 21 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
astral-tokio-tar is a tar archive reading/writing library for async Rust. Versions of astral-tokio-tar prior to 0.5.6 contain a boundary parsing vulnerability that allows attackers to smuggle additional archive entries by exploiting inconsistent PAX/ustar header handling. When processing archives with PAX-extended headers containing size overrides, the parser incorrectly advances stream position based on ustar header size (often zero) instead of the PAX-specified size, causing it to interpret file content as legitimate tar headers. This issue has been patched in version 0.5.6. There are no workarounds.
Weakness: CWE-843
Which versions are affected by CVE-2025-62518?
6 open source packages ship an affected version, including astral-tokio-tar and tokio-tar.
| Package | Affected | Fixed in |
|---|---|---|
astral-tokio-tar crates.io | All versions | 0.5.6 |
astral-tokio-tar crates.io | All versions | 0.5.6 |
astral-tokio-tar crates.io | From 0.0.0-0 | 0.5.6 |
tokio-tar crates.io | All versions to 0.3.1 | None |
tokio-tar crates.io | All versions to 0.3.1 | None |
tokio-tar crates.io | From 0.0.0-0 | None |
Linux distribution packages (1)
python-uv openSUSE:Tumbleweed | All versions | 0.9.5-1.1 |
How do I fix CVE-2025-62518?
Upgrade astral-tokio-tar to 0.5.6 or later.
Is CVE-2025-62518 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62518 exists.
Public exploit code: 2 proofs of concept on GitHub.
Sources
Also known as DEBIAN-CVE-2025-62518, GHSA-j5gw-2vrg-8fgx, MINI-7mwx-ghcw-68v7, RUSTSEC-2025-0110, RUSTSEC-2025-0111, UBUNTU-CVE-2025-62518 and 1 more.