{"answers":{"affected":"4 open source packages ship an affected version, including phpmyfaq/phpmyfaq and thorsten/phpmyfaq. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62519 exists.","fix":"Upgrade phpmyfaq/phpmyfaq to 4.0.14 or later.","what":"CVE-2025-62519 is a high-severity SQL injection vulnerability in Phpmyfaq Phpmyfaq, published on 17 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62519 and fix it if it is affected.\n\nWhat it is: CVE-2025-62519 is a high-severity SQL injection vulnerability in Phpmyfaq Phpmyfaq, published on 17 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62519 exists.\n\nAffected packages and fixed versions:\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.0.14\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.0.14\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.14\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62519/ (Markdown: https://insights.sbomify.com/CVE-2025-62519/index.md)","id":"CVE-2025-62519","markdown":"https://insights.sbomify.com/CVE-2025-62519/index.md","name":"CVE-2025-62519","record":{"aliases":["GHSA-fxm2-cmwj-qvx4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyFAQ web application","requires_auth":"high_privilege","summary":"Authenticated users with configuration edit permissions can execute arbitrary SQL commands, leading to database compromise and potential remote code execution.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"phpmyfaq","vendor":"phpmyfaq"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"phpMyFAQ is an open source FAQ web application. Prior to version 4.0.14, an authenticated SQL injection vulnerability in the main configuration update functionality of phpMyFAQ allows a privileged user with 'Configuration Edit' permissions to execute arbitrary SQL commands. Successful exploitation can lead to a full compromise of the database, including reading, modifying, or deleting all data, as well as potential remote code execution depending on the database configuration. This issue has been patched in version 4.0.14.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"phpMyFAQ has Authenticated SQL Injection in Configuration Update Functionality","id":"CVE-2025-62519","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyfaq:phpmyfaq","products":["phpmyfaq:phpmyfaq"],"type":"sql_injection","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"MantisBT unauthorized disclosure of private project column configuration","id":"CVE-2025-62520"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.14"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-fxm2-cmwj-qvx4"},{"ecosystem":"Packagist","fixed":["4.0.14"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-fxm2-cmwj-qvx4"},{"ecosystem":"Packagist","fixed":["4.0.14"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-fxm2-cmwj-qvx4"},{"ecosystem":"Packagist","fixed":["4.0.14"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-fxm2-cmwj-qvx4"}],"prev":{"headline":"astral-tokio-tar Vulnerable to PAX Header Desynchronization","id":"CVE-2025-62518"},"products":["phpMyFAQ"],"published":"2025-11-17","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0310","kev_date_added":null,"published":"2023-01-15"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq","id":"CVE-2022-4407","kev_date_added":null,"published":"2022-12-11"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2017-11187","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle","id":"CVE-2026-76213","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge","id":"CVE-2026-76214","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - DOM in thorsten/phpmyfaq","id":"CVE-2023-5316","kev_date_added":null,"published":"2023-09-30"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0306","kev_date_added":null,"published":"2023-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-17","vendors":["thorsten"]},"summary":"Authenticated users with configuration edit permissions can execute arbitrary SQL commands, leading to database compromise and potential remote code execution.","url":"https://insights.sbomify.com/CVE-2025-62519/"}