# CVE-2025-62519: phpMyFAQ has Authenticated SQL Injection in Configuration Update Functionality

> Authenticated users with configuration edit permissions can execute arbitrary SQL commands, leading to database compromise and potential remote code execution.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2025
- **Updated:** 17 Nov 2025
- **Also known as:** GHSA-fxm2-cmwj-qvx4

## What is CVE-2025-62519?

CVE-2025-62519 is a high-severity SQL injection vulnerability in Phpmyfaq Phpmyfaq, published on 17 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

phpMyFAQ is an open source FAQ web application. Prior to version 4.0.14, an authenticated SQL injection vulnerability in the main configuration update functionality of phpMyFAQ allows a privileged user with 'Configuration Edit' permissions to execute arbitrary SQL commands. Successful exploitation can lead to a full compromise of the database, including reading, modifying, or deleting all data, as well as potential remote code execution depending on the database configuration. This issue has been patched in version 4.0.14.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-62519?

4 open source packages ship an affected version, including phpmyfaq/phpmyfaq and thorsten/phpmyfaq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.0.14 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.0.14 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.0.14 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.0.14 |

Products: Phpmyfaq Phpmyfaq.

## How do I fix CVE-2025-62519?

Upgrade phpmyfaq/phpmyfaq to 4.0.14 or later.

## Is CVE-2025-62519 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62519 exists.

## Other vulnerabilities in Phpmyfaq Phpmyfaq

- [CVE-2023-0310](https://insights.sbomify.com/CVE-2023-0310/): Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq (critical 9.8)
- [CVE-2022-4407](https://insights.sbomify.com/CVE-2022-4407/): Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq (critical 9.8)
- [CVE-2017-11187](https://insights.sbomify.com/CVE-2017-11187/): Security feature bypass in n/a (critical 9.8)
- [CVE-2026-76213](https://insights.sbomify.com/CVE-2026-76213/): phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle (critical 9.1)
- [CVE-2026-76214](https://insights.sbomify.com/CVE-2026-76214/): phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62519 and fix it if it is affected.

What it is: CVE-2025-62519 is a high-severity SQL injection vulnerability in Phpmyfaq Phpmyfaq, published on 17 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62519 exists.

Affected packages and fixed versions:
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.0.14
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.0.14
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.14
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62519/ (Markdown: https://insights.sbomify.com/CVE-2025-62519/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62519
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62519
- OSV: https://osv.dev/vulnerability/CVE-2025-62519

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62519/
Summaries are generated and may contain mistakes; the official description above is the record.
