# CVE-2025-62525: OpenWrt vulnerable to local privilage escalation

> Local attackers can escalate privileges and escape sandboxes by reading/writing kernel memory via the ltq-ptm driver on specific Lantiq targets.

- **Severity:** High 7.9 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Oct 2025
- **Updated:** 22 Oct 2025
- **Also known as:** GHSA-h427-frpr-7cqr, ROOT-OS-UBUNTU-2204-CVE-2025-62525

## What is CVE-2025-62525?

CVE-2025-62525 is a high-severity vulnerability in Openwrt Openwrt, published on 22 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OpenWrt Project is a Linux operating system targeting embedded devices. Prior to version 24.10.4, local users could read and write arbitrary kernel memory using the ioctls of the ltq-ptm driver which is used to drive the datapath of the DSL line. This only effects the lantiq target supporting xrx200, danube and amazon SoCs from Lantiq/Intel/MaxLinear with the DSL in PTM mode. The DSL driver for the VRX518 is not affected. ATM mode is also not affected. Most VDSL lines use PTM mode and most ADSL lines use ATM mode. OpenWrt is normally running as a single user system, but some services are sandboxed. This vulnerability could allow attackers to escape a ujail sandbox or other contains. This is fixed in OpenWrt 24.10.4. There are no workarounds.

Weakness: CWE-787 (Out-of-bounds Write), CWE-20 (Improper Input Validation), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-62525?

It affects 1 product.


Products: Openwrt Openwrt.

## How do I fix CVE-2025-62525?

Upgrade to a fixed version.

## Is CVE-2025-62525 being exploited?

There is no known exploitation of CVE-2025-62525 in the wild and no public exploit code.

## Other vulnerabilities in Openwrt Openwrt

- [CVE-2020-28951](https://insights.sbomify.com/CVE-2020-28951/): Use after free in n/a (critical 9.8)
- [CVE-2026-62948](https://insights.sbomify.com/CVE-2026-62948/): Cross-site scripting in openwrt (critical 9.6)
- [CVE-2026-30871](https://insights.sbomify.com/CVE-2026-30871/): OpenWrt Project has Stack-based Buffer Overflow in DNS PTR Query (critical 9.5)
- [CVE-2026-30872](https://insights.sbomify.com/CVE-2026-30872/): OpenWrt Project has a Stack-based Buffer Overflow vulnerability via IPv6 reverse DNS lookup (critical 9.5)
- [CVE-2021-28961](https://insights.sbomify.com/CVE-2021-28961/): Command injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62525 and fix it if it is affected.

What it is: CVE-2025-62525 is a high-severity vulnerability in Openwrt Openwrt, published on 22 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62525 in the wild and no public exploit code.

Affected product: Openwrt Openwrt. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62525/ (Markdown: https://insights.sbomify.com/CVE-2025-62525/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62525
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62525
- OSV: https://osv.dev/vulnerability/CVE-2025-62525

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62525/
Summaries are generated and may contain mistakes; the official description above is the record.
