# CVE-2025-62527: Taguette vulnerable to password reset link poisoning


- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2025
- **Updated:** 20 Oct 2025
- **Also known as:** GHSA-7rc8-5c8q-jr6j, PYSEC-2025-187

## What is CVE-2025-62527?

CVE-2025-62527 is a high-severity vulnerability in remram44 taguette, published on 20 Oct 2025. 

### Official description

Taguette is an open source qualitative research tool. An issue has been discovered in Taguette versions prior to 1.5.0. It was possible for an attacker to request password reset email containing a malicious link, allowing the attacker to set the email if clicked by the victim. This issue has been patched in version 1.5.0.

Weakness: CWE-15 (External Control of System or Configuration Setting)

## Which versions are affected by CVE-2025-62527?

3 open source packages ship an affected version, including taguette. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `taguette` | PyPI | All versions | 1.5.0 |
| `taguette` | PyPI | All versions | 1.5.0 |
| `taguette` | PyPI | All versions | 1.5.1 |

Products: Taguette Taguette.

## How do I fix CVE-2025-62527?

Upgrade taguette to a fixed version for your release line: 1.5.0 or 1.5.1.

## Is CVE-2025-62527 being exploited?

There is no known exploitation of CVE-2025-62527 in the wild and no public exploit code.

## Other vulnerabilities in remram44 taguette

- [CVE-2025-67502](https://insights.sbomify.com/CVE-2025-67502/): Taguette does not safeguard against Open Redirect (medium 5.4)
- [CVE-2025-62528](https://insights.sbomify.com/CVE-2025-62528/): Taguette cross-site scripting vulnerability via tag name, tag description, document name and document description (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62527 and fix it if it is affected.

What it is: CVE-2025-62527 is a high-severity vulnerability in remram44 taguette, published on 20 Oct 2025. 
Exploitation: There is no known exploitation of CVE-2025-62527 in the wild and no public exploit code.

Affected packages and fixed versions:
- taguette (PyPI): affected all versions; fixed in 1.5.0
- taguette (PyPI): affected all versions; fixed in 1.5.0
- taguette (PyPI): affected all versions; fixed in 1.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62527/ (Markdown: https://insights.sbomify.com/CVE-2025-62527/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62527
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62527
- OSV: https://osv.dev/vulnerability/CVE-2025-62527

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62527/
Summaries are generated and may contain mistakes; the official description above is the record.
