# CVE-2025-62528: Taguette cross-site scripting vulnerability via tag name, tag description, document name and document description

> An attacker can inject JavaScript into project fields to execute code on other users' browsers, potentially leading to account takeover.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Oct 2025
- **Updated:** 20 Oct 2025
- **Also known as:** GHSA-g9qw-g6rv-3889, PYSEC-2025-188

## What is CVE-2025-62528?

CVE-2025-62528 is a medium-severity cross-site scripting vulnerability in remram44 taguette, published on 20 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Taguette is an open source qualitative research tool. An issue has been discovered in Taguette versions prior to 1.5.0. It was possible for a project member to put JavaScript in name or description fields which would run on project load. This issue has been patched in version 1.5.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-62528?

3 open source packages ship an affected version, including taguette. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `taguette` | PyPI | All versions | 1.5.0 |
| `taguette` | PyPI | All versions | 1.5.0 |
| `taguette` | PyPI | All versions | 1.5.0 |

Products: Taguette Taguette.

## How do I fix CVE-2025-62528?

Upgrade taguette to 1.5.0 or later.

## Is CVE-2025-62528 being exploited?

There is no known exploitation of CVE-2025-62528 in the wild and no public exploit code.

## Other vulnerabilities in remram44 taguette

- [CVE-2025-62527](https://insights.sbomify.com/CVE-2025-62527/): Taguette vulnerable to password reset link poisoning (high 7.1)
- [CVE-2025-67502](https://insights.sbomify.com/CVE-2025-67502/): Taguette does not safeguard against Open Redirect (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62528 and fix it if it is affected.

What it is: CVE-2025-62528 is a medium-severity cross-site scripting vulnerability in remram44 taguette, published on 20 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62528 in the wild and no public exploit code.

Affected packages and fixed versions:
- taguette (PyPI): affected all versions; fixed in 1.5.0
- taguette (PyPI): affected all versions; fixed in 1.5.0
- taguette (PyPI): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62528/ (Markdown: https://insights.sbomify.com/CVE-2025-62528/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62528
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62528
- OSV: https://osv.dev/vulnerability/CVE-2025-62528

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62528/
Summaries are generated and may contain mistakes; the official description above is the record.
