CVE-2025-62594 ImageMagick CLAHE : Unsigned underflow and division-by-zero lead to OOB pointer arithmetic and process crash (DoS)
Attackers can cause a denial of service in ImageMagick via crafted images triggering integer underflow and division-by-zero errors in CLAHE processing.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-62594?
CVE-2025-62594 is a medium-severity vulnerability in Imagemagick Imagemagick, published on 27 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
ImageMagick is a software suite to create, edit, compose, or convert bitmap images. ImageMagick versions prior to 7.1.2-8 are vulnerable to denial-of-service due to unsigned integer underflow and division-by-zero in the CLAHEImage function. When tile width or height is zero, unsigned underflow occurs in pointer arithmetic, leading to out-of-bounds memory access, and division-by-zero causes immediate crashes. This issue has been patched in version 7.1.2-8.
Which versions are affected by CVE-2025-62594?
24 open source packages ship an affected version, including Magick.NET-Q16-HDRI-OpenMP-arm64, Magick.NET-Q16-HDRI-OpenMP-x64 and Magick.NET-Q16-HDRI-arm64. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
Magick.NET-Q16-HDRI-OpenMP-arm64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q16-HDRI-OpenMP-arm64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q16-HDRI-OpenMP-x64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q16-HDRI-OpenMP-x64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q16-HDRI-arm64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q16-HDRI-arm64 NuGet | All versions to 14.9.0 | None |
18 more packages
Magick.NET-Q16-HDRI-x64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q16-HDRI-x64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q16-OpenMP-arm64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q16-OpenMP-arm64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q16-OpenMP-x64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q16-OpenMP-x64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q16-arm64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q16-arm64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q16-x64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q16-x64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q8-OpenMP-arm64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q8-OpenMP-arm64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q8-OpenMP-x64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q8-OpenMP-x64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q8-arm64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q8-arm64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q8-x64 NuGet | All versions to 14.9.0 | None |
Magick.NET-Q8-x64 NuGet | All versions to 14.9.0 | None |
Linux distribution packages (8)
ImageMagick SUSE:Linux Enterprise Module for Desktop Applications 15 SP6 | All versions | 7.1.0.9-150400.6.51.1 |
ImageMagick SUSE:Linux Enterprise Module for Desktop Applications 15 SP6 | All versions | 7.1.1.21-150600.3.29.1 |
ImageMagick SUSE:Linux Enterprise Module for Desktop Applications 15 SP7 | All versions | 7.1.0.9-150400.6.51.1 |
ImageMagick SUSE:Linux Enterprise Module for Desktop Applications 15 SP7 | All versions | 7.1.1.43-150700.3.22.1 |
ImageMagick SUSE:Linux Enterprise Module for Development Tools 15 SP6 | All versions | 7.1.1.21-150600.3.29.1 |
ImageMagick SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 7.1.1.43-150700.3.22.1 |
ImageMagick openSUSE:Leap 15.6 | All versions | 7.1.1.21-150600.3.29.1 |
ImageMagick openSUSE:Tumbleweed | All versions | 7.1.2.8-1.1 |
Products include Imagemagick Imagemagick.
How do I fix CVE-2025-62594?
Upgrade to a fixed version.
Is CVE-2025-62594 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62594 exists.
Other vulnerabilities in Imagemagick Imagemagick
Sources
Also known as DEBIAN-CVE-2025-62594, GHSA-wpp4-vqfq-v4hp, JLSEC-2026-928, MINI-wmcr-q98x-mqcv, OESA-2025-2587, OESA-2025-2589 and 7 more.