CVE-2025-62599 Integer overflow in Fast-DDS
Attackers can cause remote denial of service in Fast DDS by manipulating DATA submessages when security is enabled, leading to out-of-memory conditions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-62599?
CVE-2025-62599 is a high-severity vulnerability in Debian Debian Linux, published on 3 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
eprosima Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1, when the security mode is enabled, modifying the DATA Submessage within an SPDP packet sent by a publisher causes an Out-Of-Memory (OOM) condition, resulting in remote termination of Fast-DDS. If the fields of PID_IDENTITY_TOKEN or PID_PERMISSION_TOKEN in the DATA Submessage — specifically by tampering with the length field in readPropertySeq — are modified, an integer overflow occurs, leading to an OOM during the resize operation. This vulnerability is fixed in 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1.
Which versions are affected by CVE-2025-62599?
It affects 2 products.
Products include Debian Debian Linux, Eprosima Fast Dds.
How do I fix CVE-2025-62599?
No fix has been published for CVE-2025-62599 yet. Limit exposure of the affected software until one is available.
Is CVE-2025-62599 being exploited?
There is no known exploitation of CVE-2025-62599 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2025-62599, GHSA-fc3f-wcj5-5cph, UBUNTU-CVE-2025-62599.