# CVE-2025-62599: Integer overflow in Fast-DDS

> Attackers can cause remote denial of service in Fast DDS by manipulating DATA submessages when security is enabled, leading to out-of-memory conditions.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Feb 2026
- **Updated:** 9 Apr 2026
- **Also known as:** DEBIAN-CVE-2025-62599, GHSA-fc3f-wcj5-5cph, UBUNTU-CVE-2025-62599

## What is CVE-2025-62599?

CVE-2025-62599 is a high-severity vulnerability in Debian Debian Linux, published on 3 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

eprosima Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1, when the security mode is enabled, modifying the DATA Submessage within an SPDP packet sent by a publisher causes an Out-Of-Memory (OOM) condition, resulting in remote termination of Fast-DDS.
If the fields of PID_IDENTITY_TOKEN or PID_PERMISSION_TOKEN in the DATA Submessage — specifically by tampering with the length field in readPropertySeq — are modified, an integer overflow occurs, leading to an OOM during the resize operation. This vulnerability is fixed in 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2025-62599?

It affects 2 products.


Products: Debian Debian Linux, Eprosima Fast Dds.

## How do I fix CVE-2025-62599?

No fix has been published for CVE-2025-62599 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-62599 being exploited?

There is no known exploitation of CVE-2025-62599 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62599 and fix it if it is affected.

What it is: CVE-2025-62599 is a high-severity vulnerability in Debian Debian Linux, published on 3 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62599 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62599/ (Markdown: https://insights.sbomify.com/CVE-2025-62599/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62599
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62599
- OSV: https://osv.dev/vulnerability/CVE-2025-62599

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62599/
Summaries are generated and may contain mistakes; the official description above is the record.
