CVE-2025-62600 Integer overflow in Fast-DDS

High 8.6 Published Updated

Attackers can cause remote denial of service in Fast DDS by manipulating DATA submessages when security is enabled, leading to out-of-memory conditions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-62600?

CVE-2025-62600 is a high-severity vulnerability in Debian Debian Linux, published on 3 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

eprosima Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1, when the security mode is enabled, modifying the DATA Submessage within an SPDP packet sent by a publisher causes an Out-Of-Memory (OOM) condition, resulting in remote termination of Fast-DDS. If the fields of PID_IDENTITY_TOKEN or PID_PERMISSION_TOKEN in the DATA Submessage — specifically by tampering with the length field in readBinaryPropertySeq— are modified, an integer overflow occurs, leading to an OOM during the resize operation. This vulnerability is fixed in 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1.

Weakness: CWE-789, CWE-190

Which versions are affected by CVE-2025-62600?

It affects 2 products.

Products include Debian Debian Linux, Eprosima Fast Dds.

How do I fix CVE-2025-62600?

No fix has been published for CVE-2025-62600 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-62600 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62600 exists.

All Debian Debian Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2025-62600, GHSA-hvm8-mm7f-m6hc, UBUNTU-CVE-2025-62600.

Is CVE-2025-62600 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free