# CVE-2025-62608: MLX has heap-buffer-overflow in load()

> A heap buffer overflow in MLX allows attackers to cause crashes or disclose information via malicious NumPy files.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2025
- **Updated:** 21 Nov 2025
- **Also known as:** GHSA-w6vg-jg77-2qg6, PYSEC-2025-138

## What is CVE-2025-62608?

CVE-2025-62608 is a medium-severity memory corruption vulnerability in ml-explore mlx, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MLX is an array framework for machine learning on Apple silicon. Prior to version 0.29.4, there is a heap buffer overflow in mlx::core::load() when parsing malicious NumPy .npy files. Attacker-controlled file causes 13-byte out-of-bounds read, leading to crash or information disclosure. This issue has been patched in version 0.29.4.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2025-62608?

3 open source packages ship an affected version, including mlx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlx` | PyPI | All versions | 0.29.4 |
| `mlx` | PyPI | All versions | 0.29.4 |
| `mlx` | PyPI | All versions | 0.29.4 |

Products: Ml-Explore Mlx.

## How do I fix CVE-2025-62608?

Upgrade mlx to 0.29.4 or later.

## Is CVE-2025-62608 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62608 exists.

## Other vulnerabilities in ml-explore mlx

- [CVE-2025-62609](https://insights.sbomify.com/CVE-2025-62609/): MLX has Wild Pointer Dereference in load_gguf() (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62608 and fix it if it is affected.

What it is: CVE-2025-62608 is a medium-severity memory corruption vulnerability in ml-explore mlx, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62608 exists.

Affected packages and fixed versions:
- mlx (PyPI): affected all versions; fixed in 0.29.4
- mlx (PyPI): affected all versions; fixed in 0.29.4
- mlx (PyPI): affected all versions; fixed in 0.29.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62608/ (Markdown: https://insights.sbomify.com/CVE-2025-62608/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62608
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62608
- OSV: https://osv.dev/vulnerability/CVE-2025-62608

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62608/
Summaries are generated and may contain mistakes; the official description above is the record.
