{"answers":{"affected":"3 open source packages ship an affected version, including mlx. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62609 exists.","fix":"Upgrade mlx to 0.29.4 or later.","what":"CVE-2025-62609 is a medium-severity vulnerability in ml-explore mlx, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62609 and fix it if it is affected.\n\nWhat it is: CVE-2025-62609 is a medium-severity vulnerability in ml-explore mlx, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62609 exists.\n\nAffected packages and fixed versions:\n- mlx (PyPI): affected all versions; fixed in 0.29.4\n- mlx (PyPI): affected all versions; fixed in 0.29.4\n- mlx (PyPI): affected all versions; fixed in 0.29.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62609/ (Markdown: https://insights.sbomify.com/CVE-2025-62609/index.md)","id":"CVE-2025-62609","markdown":"https://insights.sbomify.com/CVE-2025-62609/index.md","name":"CVE-2025-62609","record":{"aliases":["GHSA-j842-xgm4-wf88","PYSEC-2025-139"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"MLX machine learning library","requires_auth":"none","summary":"An attacker can cause a denial of service by providing a malicious GGUF file to the MLX library, triggering a segmentation fault.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mlx","vendor":"ml-explore"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-476","name":"NULL Pointer Dereference"}],"description":"MLX is an array framework for machine learning on Apple silicon. Prior to version 0.29.4, there is a segmentation fault in mlx::core::load_gguf() when loading malicious GGUF files. Untrusted pointer from external gguflib library is dereferenced without validation, causing application crash. This issue has been patched in version 0.29.4.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"MLX has Wild Pointer Dereference in load_gguf()","id":"CVE-2025-62609","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"null_dereference","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Hono Improperly Authorizes JWT Audience Validation","id":"CVE-2025-62610"},"packages":[{"ecosystem":"PyPI","fixed":["0.29.4"],"introduced":["0"],"last_affected":[],"package":"mlx","purl":null,"source":"GHSA-j842-xgm4-wf88"},{"ecosystem":"PyPI","fixed":["0.29.4"],"introduced":["0"],"last_affected":[],"package":"mlx","purl":"pkg:pypi/mlx","source":"GHSA-j842-xgm4-wf88"},{"ecosystem":"PyPI","fixed":["0.29.4"],"introduced":["0"],"last_affected":[],"package":"mlx","purl":"pkg:pypi/mlx","source":"PYSEC-2025-139"}],"prev":{"headline":"MLX has heap-buffer-overflow in load()","id":"CVE-2025-62608"},"products":["mlx"],"published":"2025-11-21","related":[{"cvss_score":5.5,"headline":"MLX has heap-buffer-overflow in load()","id":"CVE-2025-62608","kev_date_added":null,"published":"2025-11-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-21","vendors":["ml-explore"]},"summary":"An attacker can cause a denial of service by providing a malicious GGUF file to the MLX library, triggering a segmentation fault.","url":"https://insights.sbomify.com/CVE-2025-62609/"}