# CVE-2025-6264: Velociraptor priviledge escalation via UpdateConfig artifact

> Attackers with Investigator role can bypass permission checks to update client configs, leading to arbitrary command execution and endpoint takeover.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jun 2025
- **Updated:** 28 Nov 2025
- **Also known as:** GHSA-gpfc-mph4-qm24, GO-2025-3768

## What is CVE-2025-6264?

CVE-2025-6264 is a medium-severity missing authorization vulnerability in Rapid7 Velociraptor, published on 20 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Velociraptor allows collection of VQL queries packaged into Artifacts from endpoints. These artifacts can be used to do anything and usually run with elevated permissions.  To limit access to some dangerous artifact, Velociraptor allows for those to require high permissions like EXECVE to launch.

The Admin.Client.UpdateClientConfig is an artifact used to update the client's configuration. This artifact did not enforce an additional required permission, allowing users with COLLECT_CLIENT permissions (normally given by the "Investigator" role) to collect it from endpoints and update the configuration. 

This can lead to arbitrary command execution and endpoint takeover.

To successfully exploit this vulnerability the user must already have access to collect artifacts from the endpoint (i.e. have the COLLECT_CLIENT given typically by the "Investigator' role).

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2025-6264?

3 open source packages ship an affected version, including www.velocidex.com/golang/velociraptor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `www.velocidex.com/golang/velociraptor` | Go | All versions | 0.74.3 |
| `www.velocidex.com/golang/velociraptor` | Go | All versions | 0.74.3 |
| `www.velocidex.com/golang/velociraptor` | Go | All versions | 0.74.3 |

Products: Rapid7 Velociraptor.

## How do I fix CVE-2025-6264?

Upgrade www.velocidex.com/golang/velociraptor to 0.74.3 or later.

## Is CVE-2025-6264 being exploited?

There is no known exploitation of CVE-2025-6264 in the wild and no public exploit code.

Public exploit code:

- https://github.com/Mauzy0x00/velociraptor_CVE-2025-6264_PoC (github_poc): https://github.com/Mauzy0x00/velociraptor_CVE-2025-6264_PoC

## Other vulnerabilities in Rapid7 Velociraptor

- [CVE-2023-0242](https://insights.sbomify.com/CVE-2023-0242/): Insufficient permission check in the VQL copy() function (high 8.8)
- [CVE-2023-5950](https://insights.sbomify.com/CVE-2023-5950/): Rapid7 Velociraptor Reflected XSS (high 8.6)
- [CVE-2026-5329](https://insights.sbomify.com/CVE-2026-5329/): Rapid7 Velociraptor Improper Input Validation in Client Message Handler (high 8.5)
- [CVE-2026-6290](https://insights.sbomify.com/CVE-2026-6290/): Velociraptor Query() Plugin Misapplies Permissions To Orgs (high 8.0)
- [CVE-2025-14728](https://insights.sbomify.com/CVE-2025-14728/): Rapid7 Velociraptor Directory Traversal Vulnerability (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6264 and fix it if it is affected.

What it is: CVE-2025-6264 is a medium-severity missing authorization vulnerability in Rapid7 Velociraptor, published on 20 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-6264 in the wild and no public exploit code.

Affected packages and fixed versions:
- www.velocidex.com/golang/velociraptor (Go): affected all versions; fixed in 0.74.3
- www.velocidex.com/golang/velociraptor (Go): affected all versions; fixed in 0.74.3
- www.velocidex.com/golang/velociraptor (Go): affected all versions; fixed in 0.74.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6264/ (Markdown: https://insights.sbomify.com/CVE-2025-6264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6264
- OSV: https://osv.dev/vulnerability/CVE-2025-6264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6264/
Summaries are generated and may contain mistakes; the official description above is the record.
