{"answers":{"affected":"2 open source packages ship an affected version, including mediawiki/cargo.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62671 exists.","fix":"Upgrade mediawiki/cargo to 3.8.3 or later.","what":"CVE-2025-62671 is a medium-severity cross-site scripting vulnerability in The Wikimedia Foundation Mediawiki - Cargo Extension, published on 18 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62671 and fix it if it is affected.\n\nWhat it is: CVE-2025-62671 is a medium-severity cross-site scripting vulnerability in The Wikimedia Foundation Mediawiki - Cargo Extension, published on 18 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62671 exists.\n\nAffected packages and fixed versions:\n- mediawiki/cargo (Packagist): affected all versions; fixed in 3.8.3\n- mediawiki/cargo (Packagist): affected all versions; fixed in 3.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62671/ (Markdown: https://insights.sbomify.com/CVE-2025-62671/index.md)","id":"CVE-2025-62671","markdown":"https://insights.sbomify.com/CVE-2025-62671/index.md","name":"CVE-2025-62671","record":{"aliases":["GHSA-gr6v-3pmp-996p"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki Cargo extension","requires_auth":"none","summary":"Attackers can inject malicious scripts via wikitext in the Cargo extension, potentially executing code or hijacking user accounts.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"wikimedia-foundation","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in The Wikimedia Foundation Mediawiki - Cargo Extension allows Stored XSS.This issue affects Mediawiki - Cargo Extension: master.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Stored XSS through wikitext in Cargo","id":"CVE-2025-62671","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Denial of service in rplay","id":"CVE-2025-62672"},"packages":[{"ecosystem":"Packagist","fixed":["3.8.3"],"introduced":["0"],"last_affected":[],"package":"mediawiki/cargo","purl":null,"source":"GHSA-gr6v-3pmp-996p"},{"ecosystem":"Packagist","fixed":["3.8.3"],"introduced":["0"],"last_affected":[],"package":"mediawiki/cargo","purl":"pkg:composer/mediawiki/cargo","source":"GHSA-gr6v-3pmp-996p"}],"prev":{"headline":"Stored XSS through a system message in FlexDiagrams","id":"CVE-2025-62670"},"products":["Mediawiki - Cargo Extension"],"published":"2025-10-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-20","vendors":["The Wikimedia Foundation"]},"summary":"Attackers can inject malicious scripts via wikitext in the Cargo extension, potentially executing code or hijacking user accounts.","url":"https://insights.sbomify.com/CVE-2025-62671/"}