# CVE-2025-62671: Stored XSS through wikitext in Cargo

> Attackers can inject malicious scripts via wikitext in the Cargo extension, potentially executing code or hijacking user accounts.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Oct 2025
- **Updated:** 20 Oct 2025
- **Also known as:** GHSA-gr6v-3pmp-996p

## What is CVE-2025-62671?

CVE-2025-62671 is a medium-severity cross-site scripting vulnerability in The Wikimedia Foundation Mediawiki - Cargo Extension, published on 18 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in The Wikimedia Foundation Mediawiki - Cargo Extension allows Stored XSS.This issue affects Mediawiki - Cargo Extension: master.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-62671?

2 open source packages ship an affected version, including mediawiki/cargo.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/cargo` | Packagist | All versions | 3.8.3 |
| `mediawiki/cargo` | Packagist | All versions | 3.8.3 |

## How do I fix CVE-2025-62671?

Upgrade mediawiki/cargo to 3.8.3 or later.

## Is CVE-2025-62671 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62671 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62671 and fix it if it is affected.

What it is: CVE-2025-62671 is a medium-severity cross-site scripting vulnerability in The Wikimedia Foundation Mediawiki - Cargo Extension, published on 18 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62671 exists.

Affected packages and fixed versions:
- mediawiki/cargo (Packagist): affected all versions; fixed in 3.8.3
- mediawiki/cargo (Packagist): affected all versions; fixed in 3.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62671/ (Markdown: https://insights.sbomify.com/CVE-2025-62671/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62671
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62671
- OSV: https://osv.dev/vulnerability/CVE-2025-62671

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62671/
Summaries are generated and may contain mistakes; the official description above is the record.
